Traffic Shaper - Display Notice - asking for default queue



  • Hi,

    I had setup Traffic Shaper on my WAN using the wizard (Dedicated Links), but I am not sure why I keep on getting acknowledgement notice on top saying: shaper no default queue specified for interface wan. the interface queue will be enforced as default.

    How do I set a default queue?



  • Just go the traffic shaper screen, click the queue you want as default and you will find a checkbox which says default queue.

    This might have happened because some validation were being done wrong during the wizard but are now fixed.



  • Hi,

    after upgrading to the snapshot Wed Jan 26 09:44:03 EST 2011 (full, i386), I got the following alerts:

    SHAPER: no default queue specified for interface opt3. The interface queue will be enforced as default.

    the same for interface lan.

    I double checked that there was a queue defined as default queue for each interface and that there was only one/if.
    I even unset all default queue settings and re-set them.

    But those warnings remain and appear periodically..

    I never had this problem.. and I didn't alter anything in the shaper since months.

    Does anyone know what I could do to stop that?

    Thank you very much,

    Max



  • Okay, I had tick at the qInternet, but I got error saying :  There were error(s) loading the rules: pfctl: should have one default queue on pppoe0pfctl: errors in altq config - The line in question reads [ should have one default queue on pppoe0 pfctl]: …

    Since I am not good in this, I got main queue of qInternet which got a few child queues of qACK, qOtherDefault, qP2P, qOtherHigh, qOtherLow.

    What I need is just a shaper that can cap nonproductive traffic like p2p and better manage my WAN connection by giving priority to web and email traffics.


Locked