Verizon Wireless USB760/MC760 USB Stick



  • Has anyone had any luck getting Verizon USB760/MC760 USB stick to work on pfSense 2.0? I found this thread but the steps didn't work for me (http://forum.pfsense.org/index.php/topic,32389.0.html) That thread is for a Virgin Mobile 760 but they are similar.


  • Netgate Administrator

    Which part didn't work?
    I found this:

    usb_modeswitch is not needed for this device because all you have to do is eject the fake CD-ROM to make it become a modem

    So maybe just :

    cdcontrol -f /dev/cd0c eject
    

    Steve



  • i tried the cdcontrol command but i get an error saying the command not found. I tried all the steps on my windows box. When i plug it in, it doesn't mount the cd anymore and was able to disable the built-in sd-card reader. When i plug it into my pfsense box, it sees the cd mount. Here is my system log:

    
    Jan 29 19:00:18 	kernel: cd0: Attempt to query device size failed: NOT READY, Medium not present
    Jan 29 19:00:18 	kernel: cd0: 1.000MB/s transfers
    Jan 29 19:00:18 	kernel: cd0: <novatel mass="" storage="" 1.00="">Removable CD-ROM SCSI-2 device
    Jan 29 19:00:18 	kernel: cd0 at umass-sim0 bus 0 scbus0 target 0 lun 0
    Jan 29 19:00:18 	kernel: (probe0:umass-sim0:0:0:0): SCSI sense: NOT READY asc:3a,0 (Medium not present)
    Jan 29 19:00:18 	kernel: (probe0:umass-sim0:0:0:0): SCSI status: Check Condition
    Jan 29 19:00:18 	kernel: (probe0:umass-sim0:0:0:0): CAM status: SCSI Status Error
    Jan 29 19:00:18 	kernel: (probe0:umass-sim0:0:0:0): TEST UNIT READY. CDB: 0 0 0 0 0 0
    Jan 29 19:00:18 	kernel: umass0:0:0:-1: Attached to scbus0
    Jan 29 19:00:17 	kernel: umass0: SCSI over Bulk-Only; quirks = 0x0000
    Jan 29 19:00:17 	kernel: umass0: <novatel 0="" 2="" wireless="" inc.="" novatel="" cdma,="" class="" 0,="" rev="" 1.10="" 0.00,="" addr="">on usbus4
    Jan 29 19:00:17 	kernel: ugen4.2: <novatel wireless="" inc.="">at usbus4</novatel></novatel></novatel> 
    

    usbconfig

    
    ugen4.2: <novatel wireless="" cdma="" novatel="" inc.="">at usbus4, cfg=0 md=HOST spd=FULL (12Mbps) pwr=ON</novatel> 
    

  • Netgate Administrator

    Maybe just cd0 then. I just guessed at what the fake cd drive would come up as.
    (Actually I just copy and pasted without engaging any thought!  :P)

    cdcontrol -f /dev/cd0 eject
    

    Steve

    Edit: Looks like cdcontrol isn't included in pFSense. You could copy it in from a FreeBSD box.



  • @stephenw10:

    Edit: Looks like cdcontrol isn't included in pFSense. You could copy it in from a FreeBSD box.

    i dont have a FreeBSD box setup at this moment. i'll have to look for a 8.1 livecd if there is one on the net… I'll do some searching and see if I can find one or the file cdcontrol.  Thanks again for the suggestion

    Edit: Looks like there is a freebsd 8.1 livecd from http://www.pcbsd.org/ going to give that a shot..



  • Making progress… I booted up the PC-BSD dvd. Selected option 3 to boot live. Copied cdcontrol to a usb thumb drive since PC-BSD didn't like my wireless NIC... Rebooted back into Windows and SCP the file over and corrected the permissions to 0555. Now I have a /dev/cuaU0.0 device.

    A few more clicks thru some configs and the modem connected! YAY

    Now I just have to route out of it but that's for another thread if needed.. Wanted to see if this works in-case my cable modem goes down for some reason...

    Thanks again!


  • Netgate Administrator

    Cool!  8)
    This should get reported back the u3g maintainer because it should all be taken care of automatically but looking at the source it isn't doing anything for the MC760.

    Steve



  • Do they have a website or email address to let them know my findings?

    Did some more testing last night. If i do a warm reboot, the modem is active right after reboot. If I do a shutdown(fully take power away) I have to run the cdcontrol cmd again and goto all the config screens and re-save them to be active. Which is good to know since I will be unplugging the 3G modem to take with me when I'm away but when I'm home it'll be setup for fail-over..


Locked