Realtek 8111E Driver Install (Works!)



  • Just thought I'd share some useful information for people with Realtek 8111E and other newer generation Realtek NICs.

    I've been trying to set up a Jetway JNC9C motherboard with 3 x Intel GB LAN and 2 x Realtek 8111E. The Intel worked fine, but not Realtek.

    There's been some conflicting information as to whether the RTL8111E works or not, fortunately I managed to get it working after days of frustration using this guide here (some wonderful soul uploaded a compiled driver):
    http://blog.hani-ibrahim.de/en/netzwerktreiber-auf-freenas-installieren.html

    I uploaded the file using pfSense web GUI rather than USB.

    So easy even a complete newbie like me managed it  ;D

    If you're not sure whether your new generation Realtek chipset works or not, give the above driver a try, it worked for me even though the documentation doesn't say it works.


  • Netgate Administrator

    I take it you are using 1.2.3?
    The article is from 2009 so I guess the driver is built against FreeBSD 7.X.

    Steve



  • Where exactly do you upload the compiled driver thru Web GUI?
    I'm having trouble with two Realtek PCI-E NIC not being recognized and I suspect this driver may help.

    Thanks.


  • Netgate Administrator

    It's under ->diagnostics->command->upload.
    However it's just an alternative to uploading a file any other way like scp for example.
    After you've uploaded it you'll have to kldload it from the command line to test it.

    Steve



  • got it thanks, will give this driver a try in the next few days to see if it works. Thanks.



  • I just checked my NIC card today and it it use Realtek 8168D chipset and it's actually accepted by default. I just didn't go thru the NIC assignment thinking that the auto detect can't detect an UP link.
    Now it worked just fine without any problem.

    By the way the driver mention in the above thread seem to case the kernel to get fatal exception on bootup and the kernel seems to crash and reboot in cycle.

    Thanks all.


Log in to reply