USB NIC (!!) advice…



  • Hey all,

    I know that these are horrible godforsaken devices, but I don't have a lot of options at the moment so please try and work with me on this.

    I've tried several USB NIC's in the past, and whilst they have worked in a fashion, they have either been limited to 10mbps or have suffered drop-outs. These symptoms were on 1.2.3.

    So now I am on 2.0 Beta 5, I am looking at a Belkin USB Gigabit ethernet F5D5055 adapter with the ASIX AX88178 chipset. This appears to be fully supported on FreeBSD 8.1 which 2.0 is based on right? I've just got a few questions..

    • Would it seem feasible that this adapter would provide 20-50mbps throughput on pfsense 2.0?

    • Why in the past have USB NIC's seemed hardware limited to 10mbps, even in a USB2.0 port

    • Is it likely that my traffic shaping (very basic) rules will still work?

    For reference, this NIC is likely to be paired to machine running a fast Dual Core cpu with lots of RAM etc, if that makes any odds?

    Thanks in advance for any advice on this "suspect" topic!  ;D

    Nathan


  • Netgate Administrator

    The axe(4) man page has the ASIX AX88178 listed as being 10/100. I should have thought it would be good for 50Mb though.
    A lot of usb ethernet devices were actually usb1 even though they were 'usb2.0 compatible'. Hence limited to 12Mb/s less overheads.

    To be honest I've had nothing but trouble with USB ethernet.  ::)

    Steve



  • Thanks Steve,

    I know these things are problematic and I'd like to avoid using one if at all possible, but right now it looks like it might be my only option. Believe me, if another solution presents itself I shall be on it in a flash  ;D

    I'm not sure why that chipset is showing as only 10/100 though. But if it works and gives me up to 50mbps, then I won't complain. I'll give it a try and see what happens.

    Cheers,

    Nathan


Log in to reply