LAN & WLAN im gleichen Subnetz aber andere DHCP-Ranges? (Erledigt)


  • [Bemerkung vom 08.02.2011]

    Das Problem wurde erkannt:
    Im selben Subnetz können nicht zwei verschiedne DHCP-Server adressen verteilen. Eigentlich logisch …
    Und es sollten auch nicht zwei Adapter im gleichen Subnetz sein (ausser natürlich sie sind gebridged).
    (Aus dem Interntationalen Forum)

    Hallo zusammen
    Bin seit zwei Tagen stolzer besitzer eines ALIX 2d13 und hab natürlich gleich pfsense 1.2.3 drauf geladen. Läuft (fast) alles wie am schnürchen:

    Möchte dass LAN & Wireless im gleichen subnetz sind aber verschiedene DHCP-Ranges haben. Konfiguration sieht momentan wie folgt aus:

    LAN
    Bridge with: none
    IP adress: 10.7.7.1 /23  (Ges. Subnetz = 10.7.6.0 - 10.7.7.255)

    (LAN - DHCP)
    10.7.6.2 - 10.7.6.120

    WLAN
    Bridge with: none
    IP adress: 10.7.6.1 /23  (Ges. Subnetz = 10.7.6.0 - 10.7.7.255)
    802.11g Turbo
    Infrastructure (BSS)
    …usw...

    (WLAN - DHCP)
    10.7.6.122 - 10.7.6.254

    Das Problem ist nun:
    Egal ob ich über Wireless(Laptop) oder LAN-Kabel(Tower) verbinde ich erhalte immer eine sehr hohe Adresse (10.7.6.254,253,252…) obwohl ich über das Kabel ja maximal 10.7.6.120 erhalten sollte.
    Suche nun schon ein Weilchen und kann das Problem nicht finden, Bridge ist keine eingerichtet aber vielleicht mach ich ja auch irgend ein Überlegungsfehler?

    Hoffe ihr könnt mir auf den richtigen Weg helfen :)

    Grz
    Crowner

    P.S. Zur Information:
    Da mir hier bisher niemand weiter helfen konnte, habe ich mir die Arbeit gemacht das ganze noch im Internationalen bereich zu Posten.
    Falls ich eine Lösung finde, werde ich diese natürlich an beiden Orten veröffentlichen.
    Englischer Thread: http://forum.pfsense.org/index.php/topic,33063.0.html