Unable to update pfSense 512M (28/12 version) to current (log : filesystem full)



  • Hi,

    I have a pfSense embedded 512MB running on an Alix 2D13.

    Today I tried to update pfSense of december 28th version, to the latest version of 5 februari.
    When using automatic, it claims that the file has been corrupted.
    When downloading locally on a machine, and doing the update this way, the page disappears telling me the site is unavailable.

    Tried restarting pfSense, but this came up with the same results.
    Disabled RRD graphs to free up space, since the log is telling me "filesystem full" - I gathered maybe that the RRD graphs are taking too much space… but this didn't help me.

    Then I checked for packages, but I haven't installed any !

    Then went into SSH'ing into the device, and used the command found elsewhere on this forum, to check for space eaters... nothing really strange came up... (command used : du -h /|grep M)
    The biggest chunks were :

    /usr/lib    18M
    /usr/bin    17M
    /usr/local  70M

    In total, it takes 163M
    Since nanobsd takes it apart into two chunks of 256M - I do indeed have very little place left to upgrade to a newer beta ofcourse…

    When doing a df -h command, the /dev/ufs/pfsense1 shows me that I have 43M left (I suppose the firmware download won't fit in there, since it's being 63MB in download anyway).

    Might it be time, to forget about the 512M CF card, and switch it for a 1024MB one ??  ???

    Kind regards,
    Michel



  • Reinstalled pfSense on a newer CF card.
    I have installed the 1GB version onto a 4GB flashcard.

    Now when doing a df -h command, I have 271MB available on the /dev/ufs/pfsense0 part.

    I really think that the 512MB flash image has no use anymore then ! Since I have no package installed whatsoever, 512MB images have no means of being upgraded anymore !

    Kind regards,
    Michel


Log in to reply