Made the DNS go to the LAN only, keep getting query refused?



  • I disabled any lookups externally using my ISP's dns servers.

    All I get is query refused, this is from a fresh install of the dns service, any suggestions?

    All I have is simply one A record, using www.example.com as the domain and 192.168.0.1 and setting the TTL to 24 hours being: 86400

    If someone cant give an answer for this then I will be going to IP cop as this basically works, I cant be bothered with services on this router that don't work from the word go.

    Any helps appreciated though,
    Jeremy.



  • Ah, argumentative from the start - a good way to get help (not) ;)

    What version of pfSense are you running? What version of the DNS server package did you install?



  • I will just use bind, thats pretty easy for me to setup.

    The DNS says beta on packages, must have had a dozey moment.

    Will use bind and transfer my configs over, is there any conflicts with using bind on pf sense though?

    This is copied in from the packages menu:

    dns-server Services Beta
    1.0.6.14
    platform: 1.2 Package Info pfSense version of TinyDNS which features failover host support



  • No conflict, just:

    a) You'll have to install it and manage the startup yourself (see the Packages forum)
    b) You'll have to remove the dns-server package



  • Sorry for the first post though.

    No its not really an arguement it was kind of a rant.

    But if TinyDNS won't work then, as I can see it clearly does not, don't know exactly why of course, but Bind won't be a problem for myself.

    Does PF sense have the C compilers required to install from source though?



  • I have been looking at part of this tutorial for the basic install, thought it would be best to go off a very basic install, since at the moment I am setting one up for a client of mine, thats public fancing aswell, so I am very good with configuring bind.

    Am I missing something? How to actually restart bind here?

    This is the tutorial sorry:
    http://doc.pfsense.org/index.php/Creating_a_DNS_Black_Hole_for_Captive_Portal_Clients

    Just wondered if you can see how to restart bind or whatever, its just everytime you make changes, you must restart bind, unlike I think tinyDNS, I actually prefer this method myself.

    I have created the file:

    /usr/local/etc/rc.d/named.sh and given it world readable and executable permissions, just wanted to see if it works etc.

    Then used the following asin the above tutorial:

    #!/bin/sh

    rc_start() {

    start

    if [ -z "ps auxwww | grep "named "|awk '{print $2}'" ];then
    named -u bind
    fi
    }

    rc_stop() {
    killall -9 named 2>/dev/null
    wait
    }

    case $1 in
    start)
    rc_start
    ;;
    stop)
    rc_stop
    ;;
    restart)
    rc_stop
    rc_start
    ;;
    esac

    How would I go about starting the service, restarting and stoping the dns service sorry?

    It works nslookup is resolving though, which is good!



  • I have bind working now.

    It's weird I find Bind much easier to config than something that doesnt work, I mean why get rid of the stable release but couldnt even get that working.

    Now I have a fully working dns server for my router, which is really good.

    I just ran the kill command to shut bind down, but a restart script would be allot more convenient than having to write something like this out all the time.

    Any reply is appreciated,
    Jeremy.



  • I'm sure TinyDNS would have worked - it works for many other people. I suspect a configuration issue with your TinyDNS setup.

    A quick look in the packages forum shows this sticky that's relevant to your startup/shutdown question. There still won't be anything in the GUI though, to call it manually you'll have to treat it like any other startup script (eg /usr/local/etc/rc.d/named.sh restart).



  • I prefer using Bind to be fair though.

    Feel its a much more professional DNS, but obviously does not have a failover, though I don't actually need that anyways so cannot see much point.

    Ah ok that's fair enough, but I shall keep going with bind to be fair.


Log in to reply