.97 PPPoE connection not showing in console



  • I just upgraded last night to .97 and this morning when I flipped on my pfSense monitor, my WAN interface was showing NONE(PPPoE) but the webconfigurater was showing it connected and I could surf fine.  So, it seems to be just cosmetic.



  • Please run this command from a shell prompt or exec.php:

    update_file.sh /etc/rc.banner

    And report back if it's fixed.

    Thanks!



  • When I typed it in, I got this response.

    "trying to fetch latest /etc/rc.banner
    fetch: hXXp://pfsense.com/cgi-bin/cvsweb.cgi/pfSense/etc/rc.banner?rev=1;content
    -type=text%2Fplain;only_with_tag=RELENG_1: size of remote file is not known
    /etc/rc.banner                                                            2935 B  40 kBps"

    (http typed as hXXp to prevent link in post)
    I then exit the shell back to the console menu and where all the interfaces should be listed is this.

    "Fatal error: Call to undefined function:  get_current_wan_address() in /etc/rc.banner on line 59"

    Firewall still seems to be working normal though.



  • Try issuing the command again.



  • I've tried it couple of times, even after rebooting and still get the same message.

    Edit:  Well, after a few more tries, it finally worked.  Thanks.


Log in to reply