Vnstat2 error



  • Hello, ive been running 2.0 for a few months now, works great. I installed vnstat2 in october/november sometime to log my usage since im on an unlimited plan and my downloads/uploads are not counted so i have no idea what im pushing per month (just nice to know).

    vnstat2 worked great for the first month, but then it started showing this error in the frontend on the WAN and LAN interfaces:

    Notice: Undefined index: totalrx in /usr/local/www/vnstat2/index.php on line 77 Notice: Undefined index: totalrxk in /usr/local/www/vnstat2/index.php on line 77 Notice: Undefined index: totaltx in /usr/local/www/vnstat2/index.php on line 78 Notice: Undefined index: totaltxk in /usr/local/www/vnstat2/index.php on line 78

    From then it hasnt worked at all. I didnt upgrade my pfsense box because i though it would break vnstat, but it seams it broke itself without updating. Since then i have installed/reinstalled vnstat with no luck. I have also updated pfsense to the newest version numerous times with no luck. On the latest beta (Feb 7) it installs fine and uninstalls fine with no installation errors at all, but still gives me this error at the frontend.

    Thanks



  • I've only seen those errors when there is no data in vnstat db after an install and the browser cache stores those old data (F5 for refresh). More likely is that packages do get reinstall after every boot and in that period you mention there has been some problems with the package installation process + I also update the vnstat2 package.

    If vnstati also reports errors I would remove the package, delete /cf/conf/vnstat (Database dir) and reinstall.


Log in to reply