Installation stops at 45%



  • None of my installs get past:

    /usr/local/bin/cpdup -vvv -I -o /usr /mnt/usr  (45% of total install)

    I'm installing to an external 8GB USB thumbdrive.  (High quality usb thumbdrives and i've tried multiple to rule out defective media)

    I've tried installing FROM various types of media, CD, DVD, even bootable usb memstick release.  No luck.  I can't get past 45% no matter what.  Any ideas?


  • Rebel Alliance Developer Netgate

    It may be a BIOS limitation. Are you doing the automatic installation or a custom install?

    Try doing a custom install and make about a 3-4GB slice instead of 8GB, see if that behaves any diffferently.



  • No luck.

    I'm doing a Custom install.  This time I reduced the the slice size to 3GB and the install still hung at 45%, I then tried 2G slice, even 1GB slice.  No good.

    The BIOS does not appear to be the limiting factor.  This is a new Dell R210 and I am able to select and in boot the USB drives without an issue.

    Isn't it simply copying files?  Or is there something special that occurs?


  • Rebel Alliance Developer Netgate

    Formatting the drive as a freebsd (ufs2) format filesystem, and copying files, yes.

    Have you disabled the 'virtual media' on that Dell in the BIOS?



  • Yes, i'm not doing any kind of virtual drive creation.  The BIOS sees the drives as USB drives.  During my trouble shooting i did try setting the USB emulation to display the USB drives as "Hard Drives" but this did not help and I reverted back to having them simply appear as USB.



  • You might be interested to know I just got it to work by using the 2010 Oct 26 BETA4 release.  For some reason, that release will install to the USB external thumbdrive without an issue.

    Thoughts?


  • Rebel Alliance Developer Netgate

    Far too much has changed since then to speculate, honestly. You'd have to have access to all the snapshots in between and do a binary search to find the exact point of failure.



  • Well I think I solved it fully now.

    I had to actually Enable Virtual Technology for the CPU in the BIOS.  After this the install would complete.

    I think Pfsense sees that the CPU is VT capable and attempts to load a module or service to interact with that ability.  However, even though the CPU advertises this capablity, it may not actually have the feature turned on, thus breaking the install.

    Anyway, no promises, but this worked for me.



  • I'm getting same error (STOP at 45%), when trying to do fresh install pfSense on KVM VirtualMachine, both amd64 & i386 versions, CPU in host is AMD 550 Phenom II X2.

    Host information:
    AMD Phenom II X2 550 @ 3,1 GHz, DDR3@1600
    QEMU PC emulator version 0.12.5 (qemu-kvm-0.12.5)
    2.6.32-5-amd64

    Tried with different Storage types for VM (SCSI, IDE, VIRTIO), different architectures (i686/amd64), KVM and QEMU emulators, checked:
    pfSense-2.0-RC1-amd64-20110317-0820.iso
    pfSense-2.0-RC1-i386-20110316-1024.iso
    pfSense-2.0-RC1-i386-20110316-1637.iso
    pfSense-2.0-RC1-i386-20110317-0727.iso

    some screens attached…







Log in to reply