Installation of snort FAILED!



  • Pfsense version

    2.0-BETA5 (i386)
    built on Wed Feb 9 16:14:43 EST 2011

    CPU Type Intel(R) Pentium(R) 4 CPU 1.70GHz

    I had installed squid and squidguard. Both are working fine.
    While installing snort, I am getting this message.

    Beginning package installation for snort…
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading snort and its dependencies...
    Checking for package installation...
    Downloading http://www.pfsense.com/packages/config/snort/bin/8.1x86/mysql-client-5.1.53.tbz ...  could not download from there or http://ftp2.FreeBSD.org/pub/FreeBSD/ports/i386/packages-8.1-release/All/mysql-client-5.1.53.tbz.
    of mysql-client-5.1.53 failed!

    Installation aborted.Backing up libraries...
    Removing package...
    Starting package deletion for pcre-8.10...done.
    Starting package deletion for mysql-client-5.1.53...done.
    Starting package deletion for snort-2.8.6.1...done.
    Removing snort components...
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file snort.inc could not be found for inclusion.
    Deinstall commands...
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    Cleaning up... Failed to install package.

    Installation halted.



  • Yes the mysql-client has not installed with that package for over 2 months now. The workaround is to manually install it.

    from the console run pkg_add -r http://files.pfsense.org/packages/8/All/mysql-client-5.1.53.tbz

    Then install snort. Sadly you have to repeat this after every upgrade and you will lose all the blocked hosts and the updated rules. So before you start it make sure you run the rules update.



  • Thank you,

    I will try this tomorrow.


Log in to reply