Linksys PAP2T behind 1 NIC



  • I've done a bit of research on this but there seems to be a lack of information out there for setting up VOIP adapters behind the firewall.  Bear with me :)

    So here's the general issue.

    I have 5 NIC's setup for various reasons (Media Center, Wireless, LAN, WAN, and now a VOIP adapter).  I live overseas and having a VOIP setup on my system has proven to be incredibly convenient.

    Previously I had my VOIP (Linksys PAP2T) connected to one port on my Wireless router ( VOIP->ROUTER->PFSENSE BOX).  It actually worked incredibly well and was convenient - it still works that way.  However, 3 days ago I purchased a 2.4gHz phone to deal with how crappy my previous phone was and how much I wander around while chatting on the phone.  I decided it would be nice to actually plug the VOIP adapter straight into my extra NIC that I wasn't using and be able to monitor the used bandwidth from a NIC that was simply dedicated to VOIP.  Moreover, I wanted to move the 2.4gHz phone away from my wireless router to avoid any level of interference I might experience from having multiple wireless devices running on similar frequencies.  Beyond that, my wife was getting tired of the mess of electronics sitting right next to the phone (can't blame her!).  So I moved it all…

    However, once I set everything up one one dedicated NIC, the VOIP adapter completely stopped working.  It wouldn't even recognized that there was an ethernet cable plugged into it.  The NIC wouldn't recognize any media plugged in as well.  I tested the NIC, multiple cables that worked on other NIC's.  I even went back and replugged the VOIP adapter into the linksys router, which worked.

    So the issue is that there seems to be something I'm doing wrong between the working NIC and the working VOIP adapter.  I even tried to create a crossover cable ( They don't know what the hell that is where I live) assuming that the VOIP adapter would need it being plugged straight into the dedicated NIC.

    Im not sure if this is a hardware problem or a rules problem - I lean towards a HD problem because the rules let everything pass through on my other NIC's

    I hope that all makes sense - any suggestions or previous experience would be greatly appreciated!!!

    Cheers,
    Brian



  • check
    ip/mask/gateway of pap-maybe change IP of the pap just to see what happens
    make sure interface is enabled on pfsense
    reset pap to defualts



  • Thanks for the advice - I've actually tried most of that but will do so again.  It's absolutely strange that the linksys router can handle the adapter but a standard NIC on the pfsense box can't.

    Will try all this again and report back.  Frustrating :)

    Cheers,
    Brian



  • @Arisian:

    However, once I set everything up one one dedicated NIC, the VOIP adapter completely stopped working.  It wouldn't even recognized that there was an ethernet cable plugged into it.  The NIC wouldn't recognize any media plugged in as well.  I tested the NIC, multiple cables that worked on other NIC's.  I even went back and replugged the VOIP adapter into the linksys router, which worked.

    Older NICs need a cross over cable to talk NIC to NIC. What sort of NIC is it (FreeBSD device name)? Perhaps it might work if you switched to a newer type of NIC. Maybe you have a newer type of NIC in the box. For example, igb and em are newer NICs than fxp.

    @Arisian:

    Im not sure if this is a hardware problem or a rules problem - I lean towards a HD problem because the rules let everything pass through on my other NIC's

    Firewall rules are specified per interface. Firewall rules on other NICs are irrelevant. Does the Status -> Interfaces page show the NIC in question as Status: Up Until that status is up you won't see any traffic on the interface.



  • Hey, thanks for the reply!

    That's a great suggestion of swapping the nic's out.  I had tried the device in ever single NIC but I didn't go far enough I believe.  The NIC (after butchering a cord to make it a cross over) shows that its a 10baseT/UTP media connection… which makes sense.

    I will try the device in a few other NICs though I do believe I have done that in the last few days with no success.  I believe that a crossover cable is truly my only option!

    Yeah, I knew that the firewall rules I had set were not the issue at hand!

    Will report back this afternoon (I live in China)

    Thanks again,
    Brian



  • I also have a Linksys Papt2 which is connected to Pfsense, you should try a manual reboot by typing the following code **** then 732668 into the handset.  If this doesn't work do a factory reset 73738.  Here are some other codes which you might find handy.

    Check DHCP:                                  100
    Check IP address:                            101
    Check Network mask:                      120
    Check Static Gateway IP address:      130 
    Check MAC address:                        140
    Check Firmware Version:                  150



  • Hey guys,

    There is some great information here for anyone setting up a PAPT2 behind a pfense box.

    I did, however, finally solve my problem.

    My box was put together in China from scrap parts I pulled together at a computer market.  Unfortunately, I can't find a decent quality NIC around here - which you will see was part of the problem

    I have all my other interfaces filled up with working components in my house.  Unfortunately, the interface I was trying to connect my PAP to was an older NIC.  I had to use a cross over cable as well as change the NIC that the PAP was coming out of.

    For some reason the NIC that I was using did not support data across a 10baseT/UTP connection (I wired the crossover cable myself, thus the UTP).  So I should have thought of the cross over cable right off the bat but I guess Im so used to working with newer NIC's that it's just not necisary - Also, the NIC that I had left over just didn't support the 10baseT/UTP, like I mentioned.

    I got it solved but everyone's advice was very much helpful - furthermore, Im sure people who are looking for information on this will find it helpful in the future as well.

    Cheers,
    Brian


Log in to reply