When *.pfsense.org is down, Dashboard doesnt respond well



  • How much is the Dashboard page linking to *pfsense.org website these days still? Last night when the snapshot servers went down (after 10est) my Dashboard page became somewhat un-responsive. If I clicked on let’s say System logs, it would take over a minute or 2 for that page to come up. Once on a page other then Dashboard, the Web-GUI was very responsive. Seconds to go to the Interface page and seconds for States to display.
    Once I go back to the Dashboard page, navigating to other pages would take over a minute or 2 again.
    This happen to me last night after 10est. This morning I’ve haven’t had any issues but I’m starting to experience it again around 5:45p est. Expect this time, I can’t access any pfsense sites.
    I can now access pfsense.org and my dashboard is responding again. I’m now able to access around 6pm est.
    I could be wrong here but I remember something like this happen a few months/a year ago when maintenance was being completed to the pfsense.org websites.
    Any ideas?

    Cino

    PS I probably wouldn't had noticed but i'm waiting for the next snapshot to see if upnp is fix :-)

    PSS At first I thought it was a DNS issue on my end but I tried a couple first.



  • Same issue, using the Thu Feb 10 01:59:32 EST 2011 version. I just bookmarked a page like the firewall log to start at.

    Is there a way to disable the beta from checking for a new update automatically? I tried removing the URL under firmware update. I guess we could remove the widget, but I rather like the overall system information.



  • Hmm I'm seeing this also, and I saw it a few weeks ago when deploying a nanobsd install to a NetGate box. Every click in the dashboard of a newly-installed system there there was no WAN plugged in (and never had been) took sometimes 60 seconds or longer (not immediately but after doing some configuration first) to load every page. Once I connected the WAN to the Internet, the speed returned to normal.

    Right now, when I go to the Dashboard it loads fast, but the update check is running…when I go elsewhere or try to reload it won't go anywhere until the update check is done saying "can't load updates" and then I can go anywhere full speed, until I go back to the Dashboard where it's fast on first load but hangs checking for updates again.



  • I have the same issue too.



  • +1



  • I noticed the snapshot servers are down again and my Dashboard page is experiencing the same problem again this morning, around 9:30a est.



  • same here.



  • Hi,

    I have the same problem on 2 boxes, too.

    While "Obtaining update status…" the dashboard hangs. The access to any other webGUI page is like it should be.



  • I found that if I change the updater settings to Stable Release updates, it tricks it to thinking I have the latest release and the GUI doesn't hang. Just a temporary workaround until the snapshot server comes back online.


  • Rebel Alliance Developer Netgate

    I made some commits today to handle this better. I added a 5 second timeout to the connection so it should fail gracefully in a short time. If you are on a snap from the last couple days, you can just update via gitsync until the snapshot server comes back:
    http://doc.pfsense.org/index.php/Updating_pfSense_code_between_snapshots


Log in to reply