Can't join bad company 2



  • I was playing BC2 a while ago on the Junuary 29nth build, then I just updated to February 11nth build, I can't seem to join Bad Company 2 servers, not sure if pfsense is the problem, but others with connecting issues talking about port forwarding and what not and nat problems (They aren't using pfsense)

    Any ideas what may have changed?

    Other games like CSS and what not work fine, it could just be a BC2 issue.



  • You have created your nat rule with static port right? A lot of these games don't like the ports to be re-written.



  • I would first and foremost check your firewall logs while you have the game running to see what is being blocked. 2.0 beta I believe is set to default to log anything blocked by the default rules, so you should see something in there.

    I googled bc2 ports, and came up with the below. If you forward ports remember to make your local IP static (can be done in the DHCP service via MAC address) so if you restart your PC or PFsense box, you don't loose your IP thus loosing your port forwarding rules. (Remember you need a Rule and a NAT setting)

    ports for the client are

    Port: 80 TCP
    Port: 18121 TCP
    Port: 18126 TCP
    Port: 18126 UDP
    Port: 13505 TCP



  • I play this game from time to time. You don't need to forward any ports. Just setup a static ip for your ps3 and setup a static nat rule. Done.



  • That's the thing I have static ports setup for everything. Let me double check.



  • Honestly unless you're hosting a game you should be ok. Make sure your outbound under NAT is set to automatic.

    @jigglywiggly:

    That's the thing I have static ports setup for everything. Let me double check.


Log in to reply