Openvpn client fails to start



  • 2.0-RC1 (amd64)
    built on Sun Feb 13 23:53:14 EST 2011

    I see the following messages in my system log about 9 times immediately after updating to the RC:

    Feb 14 00:14:31	check_reload_status: syncing firewall
    Feb 14 00:14:31	php: : WARNING! Configuration written on bootup. This can cause stray openvpn and load balancing items in config.xml
    Feb 14 00:14:31	check_reload_status: syncing firewall
    Feb 14 00:14:30	php: : WARNING! Configuration written on bootup. This can cause stray openvpn and load balancing items in config.xml
    

    I had openvpn running as a client, connecting to a remote server. It worked until the system update, but not since. Status | Services says openvpn is not running and I have not access to the remote network.



  • Check your OpenVPN logs, does it give you this error?

    Feb 14 01:59:29    openvpn[62233]: Use –help for more information.
    Feb 14 01:59:29    openvpn[62233]: Options error: Bad local port number: 0

    http://forum.pfsense.org/index.php/topic,33277.0.html



  • Indeed.


  • Rebel Alliance Developer Netgate

    I'm looking into a fix… for now you can get around it by putting in a distinct, random port number in the 'local port' box for each client.



  • Thanks, that worked. I'll follow the other thread.


Log in to reply