Squid issue (transparent mode)



  • Hi guys,

    I am sorry if this is not the right forum or if this issue has been resolved already. I have been reading/searching this forum for three days now and it looks like this or similar problems have been discussed and resolved in the past.

    We have been running 1.2 for a long time with one of the pf machines running over a year without a single reboot.

    Now, I installed 2.0 version: 2.0-BETA5  (i386) built on Sun Feb 6 23:54:00 EST 2011 on IBM server with 4G RAM. I tried more recent snapshots with similar effects.

    The problem is when squid is run as transparent mode it kills captiveportal, dhcpd and dnsmasq. At first it looks like all services are running but squid is not caching anything. When I reboot the machine, only squid is green and running on on the "services status" page. We have to restart captive portal from shell. After the captive portal, dhcp starts accepting clients if restarted manually but there's no internet connection.

    If I go to the interfaces page and click "save" on the WAN interface page, the pf machine gets internet connection and clients get only dns results without any actual connection. Like if a client machine pings yahoo.com it will get the right IP address with no replies. I did a little packet capture when a client was trying to ping yahoo.com. The result is that the WAN interface receives reply from the external host but doesn't properly forward it to the client.

    Then I tired squid3 and Lusca/cacheboy with same result.

    All firewall, cp, nat, etc configurations were copied from pf 1.2 in production facility.

    I am wondering whether I have done something wrong or it has something to do with the few snapshots I tried.

    Thanks in Advance.

    Andy.



  • Looks like I hit a brick wall :)

    In summary, squid (transparent) kills cp, dns and dhcp :(

    any solution/suggestions/pointers?

    Thanks in advance.

    Andy.



  • Not sure if this is related, but I have a problem with squid transparent where wildcards are a little screwy. Noticed when using utorrent's port test to verify I had the needed ports open, and when the URL is missing "www" I get spaghetti back in the URL. For for me at least it's modify the URLs. I will enable captive portal and see if I can recreate your problem.

    BTW how is your captive portal set up, is it credential/vouched based?

    @andy11:

    Looks like I hit a brick wall :)

    In summary, squid (transparent) kills cp, dns and dhcp :(

    any solution/suggestions/pointers?

    Thanks in advance.

    Andy.



  • Do you have only squid installed or any other package like squidguard or havp? Could you please supply the squid-log and/or systemlog? that would help much in clearing up what happens here. I have had the same probs with squid3, in conjunction with squidguard.
    Maybe your prob is the same. But any logs would help.



  • After enabling captive portal, I did have the issue of no pages loading. I then tried accessing pfsense directly and it worked. So it did seem like a DNS issue, then I remember I set my DNS servers to google's 8.8.8.8, and that was being served through the DHCP. After deleting the entries, and renewing the client's IP information (updating it to the pfsense box now) it went straight to the captive portal.

    It works for me currently with Squid (not v3) / squidguard / lightsquid.



  • thnx guys. no other packages, only squid. I wanted to make squid work before I install squidguard, etc. I am going to post logs as soon as I get access to the machine - about 4 to 5  hours from now.



  • For anyone who might encounter with this problem, I tried to replicate it on another machine by installing 1.2 and upgrading to the same snapshot and packages. The second machine worked flawlessly although it had fewer interfaces and firewall rules. I will post if I find anything when I try to work on the original machine.

    adios


Log in to reply