New embedded install won't boot USB



  • I installed this snapshot pfSense-2.0-BETA5-1g-i386-20110218-0801-nanobsd.img.gz to a new USB stick from Linux according to the HOWTO: zcat pfSense-2.0-BETA5-1g-i386-20110218-0801-nanobsd.img.gz | dd of=/deb/sdb bs=16k, but when I try to boot from that USB stick I get only a flashing cursor on a black screen after the post.

    The USB device is recognized in the BIOS and set as the first boot device. The same hardware and USB device boots Askozia fine when imaged via the same method. The same hardware booted a pfsense image roughly 3 weeks ago. Is there a known problem with the later images, or did I just forget something in the last 3 weeks?


  • Rebel Alliance Developer Netgate

    Embedded images only output to serial. Were you watching the monitor or a serial console?



  • Admittedly, the VGA monitor, however in such a case I usually see

    1. the initial signs of the boot loader
    2. Activity (flashing) on the USB stick
    3. network connectivity after boot

    when things are working. In this case I see none of the above, so I'm pretty sure nothing is happening. I could confirm with a serial connection, but I didn't bother for lack of evidence that it was booting.

    I mentioned earlier that askozia boots on the same hardware using the same imaging method. I have since confirmed that the pfsense memstick installer also boots on the same hardware with the same method.


  • Rebel Alliance Developer Netgate

    Not sure what to tell you then except to double check the serial console to see if anything does show up there. The other images you're trying output to VGA, so it's not an issue there.

    Also you might give last night's snapshot a try instead of the one from the 18th.



  • Hooked up a serial cable, no output at all.

    I'm trying to recall if I've ever installed pfsense to a USB stick and booted it. I think I have. I can't believe it's not working now. I've tried 3 different sticks. Other images boot fine, but not pfsense. Maybe this motherboard is really fussy?



  • are you sure you are using a null modem cable?  also, if you connect pin 2 to pin 3 on the end of your serial cable, can you see yourself type?  even it that test woks, you still might be using a straight not a null modem cable but it does test about everything else.

    Roy…



  • Yeah, it's my only 9-pin cable. I have watched older pfsense CF installs boot with it, and askozia recently.

    Has anybody else tried to image and boot a snapshot image lately? Am I taking crazy pills?



  • I'll load one up with the latest snap and give it a try.

    Roy…



  • the latest nanobsd boots from my usb stick and displays lots of stuff on the serial console but it finally comes up with an error and reboots.  it may be the hardware as I have never tried this configuration on it before.

    Roy…



  • I was unable to install from the memstick installer (wouldn't even run live–lua errors and kernel panic) and CD installer (ran live, but couldn't find target device partly through install). Between my hardware and the pfsense USB tools, something is seriously rotten.

    What's really odd is that I did once successfully boot (most of) this hardware from the embedded image on USB. Only two things have changed since then, and that is my CPU and my BIOS. I had to update the BIOS to accommodate a newer CPU. Since then I have reset the BIOS to default a couple times, and changed every setting imaginable one at a time, but to no avail.


Log in to reply