Update runs wrong (amd64)

  • I installed a brand new snap from iso, which worked more or less flawless:
    With a geom-mirror and preparing disk (format, partition) on several pages an error 2 popped up. It was due to the fact that i made separate slices. Tried several times, same errors popped up. But installation was made without any new errors.

    Then restored my config (was an i386 2.0 install, due to change of hardware.) At reboot no package was installed automagically. Packages listed "no installed package". Had to install all packages by hand. At the Backup/restore-page there was not the "reinstall all packages". :(

    Now updated the pfSense via automatic update and the new snap is now an i386. What could be happened here? Thats a really annoying big bug! that should not happen! At the update-settings-page it was set to "AMD 64 snaps". I controlled that before updating.

    edit: after the update the setting is "i386 snaps".

  • Update: Selecting an amd64-snap and updating again resulted in a "working" installation, but useless: See pic.
    shell-access doesn't work too…
    Any hints?


  • Rebel Alliance Developer Netgate

    I'd wipe and reinstall. Something you did initially probably caused it to grab an i386 snapshot, because by default it factors the architecture into the update URL:

    	$arch = php_uname("m");

    It wouldn't switch between i386/amd64 unless the wrong URL was chosen from the drop-down box on the firmware update settings, overriding the automatic choice.

    As for getting both of those messages at the same time, apparently the firmware update was started before the package reinstall function was finished, which is bound to cause some issues.

  • ok. I'll do so. Thanks

    I did the check just before updating (first update after installation), to have security about the right update-path. Really strange.
    After the initial install i waited nearly 5 hours to get shure the packages are installed completely. (No one was installed instead.)

Log in to reply