Reach the modem on the WAN port



  • I have an ADSL modem connected to the wan port.
    Via the ssh I can ping my modem at 192.168.100.1, but how can I reach it from the other PC connected to the LAN port
    I need to be able to see the admin web pages of the modem.
    It's possible to modify the route to do this? Or there is another way?

    Thank you!



  • No help?



  • Just type the address in your webbrowser.

    ie: http://192.168.100.1

    It works for me. Although for some reason it doesn't work properly in Firefox, only in ugh Internet Explorer.

    Superman…



  • @Superman:

    Just type the address in your webbrowser.

    ie: http://192.168.100.1

    It works for me. Although for some reason it doesn't work properly in Firefox, only in ugh Internet Explorer.

    Superman…

    For me is not the same…
    Any other ideas?



  • Maybe it's because of the network range & subnet you are on. I'm on the 192.168.1.x/24 (255.255.255.0) range so my modem is on the same subnet. If you are on a different range (ie: 10.0.0.x) you can probably get there, but you'll have to do so differently…I'll leave that to the networking experts to explain, or for you to google...



  • I thought the same….
    I'll do some test soon...

    Thanks!



  • Seems like you have the option check to block private networks (had this same problem with a test firewall behind a real firewall)
    in the web interface go to "interfaces" > "wan" uncheck "Block private networks" that should do it for ya.

    Hope it helps.



  • @epsilon:

    Seems like you have the option check to block private networks (had this same problem with a test firewall behind a real firewall)
    in the web interface go to "interfaces" > "wan" uncheck "Block private networks" that should do it for ya.

    Hope it helps.

    I uncheck "Block private networks" and "Block bogon networks" but I can't reach the modem.



  • As you use pppoe I doubt that it's doable as everything gets routed into the pppoe wan encapsulation and this way bypasses the modem inside the "pppoe tunnel".  :-\



  • @hoba:

    As you use pppoe I doubt that it's doable as everything gets routed into the pppoe wan encapsulation and this way bypasses the modem inside the "pppoe tunnel".  :-\

    But I can Ping the Modem… this is trange... But I can't open the web page...



  • Ok, reset all…
    I have done a mistake...

    so...
    My modem has IP: 192.168.222.254 mask 255.255.255.252 (/30)
    I connect to internet via WAN interface via PPPoE.
    My Lan IP is 192.168.0.x 255.255.255.0
    My OPT IP is 192.168.1.x 255.255.255.0

    In SSH in the pfSense PC, if I try to ping:

    # ping 192.168.222.254
    PING 192.168.222.254 (192.168.222.254): 56 data bytes
    ^C
    --- 192.168.222.254 ping statistics ---
    3 packets transmitted, 0 packets received, 100% packet loss
    
    

    Now I try to add the IP to the WAN interface in the same subent of the modem:

    # ifconfig fxp0 inet 192.168.222.253 netmask 255.255.255.252
    

    Now I can ping the modem:

    # ping 192.168.222.254
    PING 192.168.222.254 (192.168.222.254): 56 data bytes
    64 bytes from 192.168.222.254: icmp_seq=0 ttl=64 time=0.959 ms
    64 bytes from 192.168.222.254: icmp_seq=1 ttl=64 time=0.465 ms
    64 bytes from 192.168.222.254: icmp_seq=2 ttl=64 time=0.445 ms
    64 bytes from 192.168.222.254: icmp_seq=3 ttl=64 time=0.505 ms
    ^C
    --- 192.168.222.254 ping statistics ---
    4 packets transmitted, 4 packets received, 0% packet loss
    round-trip min/avg/max/stddev = 0.445/0.594/0.959/0.212 ms
    
    

    If I do a tcpdump:

    # tcpdump host 192.168.222.254
    tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
    listening on fxp0, link-type EN10MB (Ethernet), capture size 96 bytes
    
    

    and do a Ping to the modem in the Guiweb interface, I have:
    in web interface:

    Ping output:
    
    PING 192.168.222.254 (192.168.222.254) from 82.54.197.133: 56 data bytes
    
    --- 192.168.222.254 ping statistics ---
    3 packets transmitted, 0 packets received, 100% packet loss
    
    

    and in SSH (tcpdump):

    11:55:00.868368 IP host133-197.pool8254.interbusiness.it > 192.168.222.254: ICMP echo request, id 46596, seq 0, length 64
    11:55:01.869104 IP host133-197.pool8254.interbusiness.it > 192.168.222.254: ICMP echo request, id 46596, seq 1, length 64
    11:55:02.869955 IP host133-197.pool8254.interbusiness.it > 192.168.222.254: ICMP echo request, id 46596, seq 2, length 64
    
    

    And I can't reach the web gui of the modem…

    What's wrong?
    I've to add a rule to the firewall? or a static route?

    Someone could help me?

    Thanks!



  • on interfaces wan
    uncheck this option:

    Block private networks
    When set, this option blocks traffic from IP addresses that are reserved for private
    networks as per RFC 1918 (10/8, 172.16/12, 192.168/16) as well as loopback addresses
    (127/8). You should generally leave this option turned on, unless your WAN network
    lies in such a private address space, too.



  • @jeroen234:

    on interfaces wan
    uncheck this option:
    Block private networks

    I'be tryied yet. but this can't resolve mu problem…

    If I try to reach the admin page of the modem I have in TCPDUMP:

    # tcpdump host 192.168.222.254
    tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
    listening on fxp0, link-type EN10MB (Ethernet), capture size 96 bytes
    13:45:14.913202 IP 192.168.0.2.60075 > 192.168.222.254.http: S 1540192494:1540192494(0) win 65535 <mss 1460,nop,nop,sackok="">13:45:17.758525 IP 192.168.0.2.60075 > 192.168.222.254.http: S 1540192494:1540192494(0) win 65535 <mss 1460,nop,nop,sackok="">13:45:23.738859 IP 192.168.0.2.60075 > 192.168.222.254.http: S 1540192494:1540192494(0) win 65535 <mss 1460,nop,nop,sackok="">13:45:43.606339 IP host92-60.pool8250.interbusiness.it > 192.168.222.254: ICMP echo request, id 13315, seq 0, length 64</mss></mss></mss> 
    

    What I can do else?



  • No help?  :(



  • the probleme is pppoe that is boulding a tunnel between pfsense and youre isp
    when pppoe is active the modem is completly pased and youre pings end up at the isp end of the pppoe tunnel not at the modem



  • @jeroen234:

    the probleme is pppoe that is boulding a tunnel between pfsense and youre isp
    when pppoe is active the modem is completly pased and youre pings end up at the isp end of the pppoe tunnel not at the modem

    I understand this…
    But I can reach the modem using the SSH in the pfSense...so I think that should be possible to route some pachet from the lan interface directly to the WAN interface (where I added the IP addres in the modem LAN) and not in the PPPoE tunnel...
    But I'm not so skilled in BSD networking...

    Some help?



  • Hi,
    make sure you have NAT on WAN IF, if not you will need to add static routes in the modem for your LAN and opt's.



  • @eskild:

    Hi,
    make sure you have NAT on WAN IF, if not you will need to add static routes in the modem for your LAN and opt's.

    Could you please explain me what I've to do? Thanks!


Locked