Trouble increasing kern.ipc.somaxconn



  • With the default install of pfSense kern.ipc.somaxconn=128.

    This is shown by sysctl -a | grep kern.ipc.somaxconn :
    kern.ipc.somaxconn: 128

    One can increase this value from the command line by sysctl -w kern.ipc.somaxconn="4096" :
    kern.ipc.somaxconn: 128 -> 4096

    I should be able to add kern.ipc.somaxconn="4096" or kern.ipc.somaxconn=4096 to /boot/loader.conf or to /boot/loader.conf.local or to /etc/sysctl.conf.  Unfortunately, when I make those changes and reboot, I still see kern.ipc.somaxconn: 128.  The boot time changes do not seem to be taking effect.  How can I change somaxconn at boot time or why are the settings not taking effect?

    Thanks!!



  • Your change needs to go into sysctl.conf. On pfSense 2.0 snapshot builds sysctl setting can be changed through web GUI: System -> Advanced, click on  System Tunables tab.

    I suspect sysctl.conf gets overwritten on reboot.



  • Using System Tunables made all the difference.  Thank you.


Log in to reply