Crash after WLAN setup … wont boot anymore



  • I have a Atheros based WLAN which i placed in my Alix board an which is recognized well within pfSense. I assigned the interface on the console and configured it in WebGUI. I was wondering why i didn't found the option to bridge the WLAN with the LAN. Normally the option should be there if i set the interface to "Static" … but it wasnt there. I'd configured the interface to "None" and continued my configuration.

    After that my Laptop told me that he has a working WLAN connection. No traffic passes. After that i set the rules to pass any to any on LAN and WLAN. Also no traffic passes. Then i found (for me) new Options inside the "Assign Interfaces" dialog in WebGUI. I played around with it - found something with "bridging" and "wireless" ... i cant say exactly now, what was my last click ... then a reboot occured.

    My box is now every time restarting while booting ("starting Firewall..."). I tried to press "1" at the bootup screen to boot from my alternate slice. But this seems not to work. Maybe it is not possible to switch bootslice via putty? Dont know.

    I searched in docs.pfsense.org but cant find anything how to set up a WLAN now. Normallly i would try this and can get this to work intuitionally. But it didnt work and beyond that i locked me out?

    Does anybody know what i'm doing wrong or how to setup a WLAN properly in 2.0?



  • Either set it up using an IP address (own network interface) or bridge it to LAN as you'd like to. You configure your bridge under Interfaces->(assign)->Bridges…



  • Since snapshots server down actually i was looking for a older beta2. I found one, installed it and configured interfaces via console (add ath0 as opt1). In the WebGUI i configured the rest of the settings in opt1. After that going in to the bridge section inside assign interfaces and build a bridge between opt1 and lan … and it works now.

    This also looks for me a easyer solution than described here: http://forum.pfsense.org/index.php/topic,20917.msg107386.html#msg107386

    Don't know what happened before exactly. But btw ... should it not be useful to have a "restore factory defaults" option at bootup? Or maybe how can i define the other boot slice while booting ... just pressing 1 or 2 did nothing!?



  • Pressing 1 or 2 should suffice and always worked for me…



  • I had to correct my conclusion above … WLAN is not working  :'(

    I read a many other posts (some of you too) which gave me some hints. It's seemes that i have to create a "virtual" interface which should be mapped to a physical port eg. VR0 (which is my LAN port now), and one which is my WLAN. Then put both in a bridge and assign the bridge to the formerly LAN interface. My Problem is, that it is knocking me out at the moment after i did this.

    Unfortunaly pressing 1 or 2 (connected over the serial console) works not at my Alix while booting. Maybe it works on a real PC.

    When i figured out, how to set up this, i will write a small instruction ... thx for your help.



  • I am also running pfSense on Alix…



  • Problem was, i was to lazy to change the baudrate to 9600 in the bios of my brandnew alix in fact of pfSense switches itself to 9600. I thought this could not be the problem, since you can view the boot progress and you can read in clear types which slice should start. But pressing 1 or 2 did nothing.

    So i switched bios preset com1 to 9600 - that fixed it. For everybody with Alix: Set your putty (or your console app you prefer) to 38400 and boot up. While memory counts up … press "S" and follow the instructions to change to 9600. Then quit and save ...



  • Well it should be known for long now that you need 9600 for pfSense on Alix ;)


Log in to reply