Squidguard slows internet speed



  • Hi guys,

    Ok i know i'm new in this forum and in this proxy filtering thing. I have problem with my squidguard quite for a long time. I have tried everything i found in this forum board to solve my problem, but nothing seems to be a solution to my problem.

    Case 1:
    When i installed pfsense, squid and squidguard for the first time, all seems to be perfect and worked like a charm. I was very impressed. All my boss's needs has been fulfilled like schedule, block specific website during office hour for specific IP and many more. But now i think something is blocking the process or cache or whatever, im not very familiar with this software yet. When i surf the net with Chrome, error appear and has a note under the Chrome's error handling message, something like "ERROR:: bla..bla..bla.. CACHE bla..bla..bla..".

    Case 2:
    This is different and i'm quite sure it is squid's problem. When i try to browse a website, and it is not in filtering list, error message appear at it stated that it cannot be resolve by dns server. And below the message stated "loacalhost" and "squid". It happen to youtube sometime. Why would i block youtube… sigh

    Then i try to stop both squid and squidguard services. They stop for a while but start after few seconds. Internet are slowing down all the time and the problem keep repeating itself and i have to explain to my boss with techie words and terms. LOL. Now i have uninstalled both things and my internet connection is extremely fast like i never had this type of connection.

    So guys, please please please help me. If this topic is not in the right category, please forgive me.



    1. We'd need something much more precise than "ERROR:: bla..bla..bla.. CACHE bla..bla..bla..". That could be any one of Squid's error messages.

    2. Exactly how have you configured these filtering lists - whitelists, blacklists…? Did you configure them in Squid or Squidguard?

    The more (relevant and useful) information you can provide the easier it will be to help you ;)



  • After re-installation, the problem in Case 1 is not showing up anymore. Weird..

    But for Case 2, the screenshot is in the attachment. FYI, my ISP blocked the website long time ago, government opposition thingy that i dont want to know about, along with porn website. :D

    I set up filtering list in Squidguard (Target Categories). Plus ACL and Times.

    So, i had to change DNS setting in my LAN properties. Im using Google's public DNS. Without Squidguard installed, i can get through to the website. When i installed Squidguard last month, all seems to be okay for awhile until 2 or 3 days ago.

    Now my internet speed is ok, with Squid and Squidguard installed. Case 1 problem is not showing up anymore, i dont know why. The problem happen when internet speed is slow.




  • One more error: see attachment




  • The first of those didn't help since you stripped out the details, but the second helps a bit.

    Now can you post your Squid and Squidguard configurations?



  • I only touched 2 things. One in Squid and 1 in squidguard. Details in the attachment.






  • Does DNS lookups from the pfSense host normally work? Have you checked that the DNS server(s) configured are responding?



  • In System > General Setup, i put in Google's Public DNS into both text field, and untick "Allow DNS server list to be overridden by DHCP/PPP on WAN". I think the DNS are working because I can get through any website, but sometimes it returns DNS error.



  • Then the problem may be between you and Google's DNS servers (it may even be with your connection to your ISP). Diagnosing intermittent faults is very difficult.

    The next time it happens try:

    nslookup www.google.com 8.8.8.8
    nslookup www.google.com 208.67.222.222
    nslookup www.google.com 216.146.35.35

    If all 3 of those fail then it means that your problem is probably with your ISP or your connection to them.  You can also try ping 8.8.8.8 - that should respond if your connection is working.



  • Great!!!! My problem is now solved!!!!

    But.. :D the internet speed lil bit slow. It's ok, not affecting our job so much. I have one more question, what if I put bigger amount in "Hard disk cache size", from 1000 megabytes to 9000 megabytes for example. Does it improves anything?



  • Just experiencing a very slow internet speed. Very unusual, this one. Error like Reply #3.

    But then i try the DNS above:
    208.67.222.222
    216.146.35.35

    Seems to be okay… Let give it a moment..  ::)

    **Update
    See attachment






  • And if you try 8.8.8.8 at the same time?


Log in to reply