Upgrade from 1.2.3 to 2.0 RC1 produces endless Interface Assign loop



  • Hi,

    don't know is that the right place, but i've didn't seen a way to add a ticket to the bugtracker.

    As i wise guy i've tried to upgrade a non critical router (at my home) to 2.0 RC1 in preparation to do the same on a more critical router (they really need's that update, cause with RC1 they could use MultiWAN-Proxy Feature, whats not possible with 1.2.3)

    Now the Problem:
    I've used the webinterface, selected under the Updater Settings the Beta i386 Mirror and pressed the update button. He downloads, said something about reboot and i've waited. After some times i looked direct on the router and he said that i have to asign the interfaces … i hoped that he use the configuration of 1.2.3 for basic ip setting, but he does not  :(
    But that was not a real problem, not nice, but ok, cause it's my homerouter. Now i've tried to assign interfaces, but he couldn't save the configuration. I was in a loop: I've assigned interfaces, and after the last question (proceed?) he said i have to assign interfaces. I've tried automatic and manual, nothing helped. I've not the exact error he he gaves me, cause my family was in my neck ("where is the internet? I need internet! [Add endless loop here :P ])
    I've downloaded the ISO from the webpage and reinstalled the router to get my Internet back.

    Now i'm a bit feared about upgrading the critical router, cause i can't put a monitor on em and i can upgrade that box only from remote. Is that a know bug, is it something that shouldn't be or is it generaly not supported to upgrade from 1.2.3 via Webinterface?



  • Hi,
    i had the same problem:
    http://forum.pfsense.org/index.php/topic,33790.0.html

    In Short: you have "Umlaute" somewhere in your config, probably in the description field. Get rid of them and it'll work.

    Have fun,
    Christoph



  • using umlauts seems to be a real critical thing, sometimes they are allowed, sometimes not. It looks as if always other routines are used for descriptions which results in really strange results. I hope this will be repaired till release, because being german i want to use that umlauts…

    Don't know how the situation will be for spanish/french people with even more diacritical signs... ;)


  • Rebel Alliance Developer Netgate

    If you add them once you're in 2.0 it's fine, on supported fields - the problem is that 1.2.3 would usually explode upon seeing the special characters, so I'm shocked the old config was working at all in the first place on 1.2.3.



  • K, so, if i check my critical box for special characters it should be ok?

    To be sure i will do a 1.2.3 VMWare-Machine and upgrade that to 2.0, only for me and to have a good feeling :D

    Thx for the help, m8 :)


  • Rebel Alliance Developer Netgate

    Yeah, check through the config for special characters and remove them - I run the configs through xmllint and it usually will show right where the issue is, since special characters are forbidden in the xml spec (you have to use entities or cdata escape them).



  • I tried to do an update from the firmware tab automatically and it said the update went successful, but it was not ok after it rebooted. I was able to ping the LAN interface, but nothing beyond that. I was not able to access the web gui either?

    I reverted back to 1.2.3-RELEASE and uploaded my configuration and was operational in about 30 minutes. Should I have done the update manually? I seen where someone said it worked for them on this post.

    Also I was wondering if I did a fresh install of 2.0 RC1, will it except a configuration file backup from 1.2.3-RELEASE?

    Thanks Again


  • Rebel Alliance Developer Netgate

    You can restore a 1.2.3 config to 2.0, yes, provided it's a valid config.

    Normally an auto update is fine, manual updates should work for sure, but failing all that a wipe and reload isn't a bad idea if it's convenient to do.



  • Good to know the backup file will work, but how would you make sure that it is a valid con-fig file?


  • Rebel Alliance Developer Netgate

    The most common thing wrong with a 1.2.3 config that breaks on the way to 2.0 is, as mentioned earlier in this thread, international characters (umlaut, circumflex, and other diacritical marks).

    If you have access to the xmllint tool, the easiest way is to run it through there and see if any errors are kicked back.


Log in to reply