RRD Creation fails after Upgrade to 2.0RC (nanobsd)



  • Hi,
    I did an upgrade from 1.2.3 to 2.0RC (nanobsd) and I see an error message when i try to check the "traffic"-rrd graphs. CPU graphs work fine. In the system log i see the following entry:

    /status_rrd_graph_img.php: Failed to create graph with error code 1, the error is: ERROR: No DS called 'inpass' in '/var/db/rrd/wan-traffic.rrd'/usr/bin/nice -n20 /usr/local/bin/rrdtool graph /tmp/wan-traffic.rrd-4year.png –start 1172579695 --end 1299069295 --vertical-label "bits/sec" --color SHADEA#eeeeee --color SHADEB#eeeeee --title "hostname - WAN :: Traffic - 4 years - 1 day average" --height 200 --width 620 DEF:wan-in_bytes_pass=/var/db/rrd/wan-traffic.rrd:inpass:AVERAGE DEF:wan-out_bytes_pass=/var/db/rrd/wan-traffic.rrd:outpass:AVERAGE DEF:wan-in_bytes_block=/var/db/rrd/wan-traffic.rrd:inblock:AVERAGE DEF:wan-out_bytes_block=/var/db/rrd/wan-traffic.rrd:outblock:AVERAGE CDEF:"wan-in_bits_pass=wan-in_bytes_pass,8," CDEF:"wan-out_bits_pass=wan-out_bytes_pass,8," CDEF:"wan-in_bits_block=wan-in_bytes_block,8," CDEF:"wan-out_bits_block=wan-out_bytes_block,8," CDEF:"wan-in_bytes=wan-in_bytes_pass,wan-in_bytes_block,+" CDEF:"wan-out_bytes=wan-out_bytes_pass,wan-out_bytes_block,+

    Any ideas?

    Thanks,
    Christoph



  • Same here, with the latest snapshot.

    EDIT:
    the issue seems to be gone
    rm /var/db/rrd/*.rrd
    disable/enable RRD graphing backend



  • Save error here, I probably could fix it by clearing the RRD graphs but I'd really rather not clear all the history like that. Any way to fix it without clearing?



  • Did a ls in the RRD directory and it seems that packets/traffic info isn't being written, which is probably tied to the issue:

    [2.0-RC1][admin@router.local]/root(8): ls -l /var/db/rrd/
    total 4024
    -rw-r–r--  1 nobody  wheel   47608 Mar  6 02:12 GW_WAN-quality.rrd
    -rw-r--r--  1 nobody  wheel  130760 Mar  3 02:09 ipsec-packets.rrd
    -rw-r--r--  1 nobody  wheel  130760 Mar  3 02:09 ipsec-traffic.rrd
    -rw-r--r--  1 nobody  wheel  130760 Mar  3 02:09 lan-packets.rrd
    -rw-r--r--  1 nobody  wheel  130760 Mar  3 02:09 lan-traffic.rrd
    -rw-r--r--  1 nobody  wheel  130760 Mar  3 02:09 opt1-packets.rrd
    -rw-r--r--  1 nobody  wheel  130760 Mar  3 02:09 opt1-traffic.rrd
    -rw-r--r--  1 nobody  wheel   97672 Mar  6 02:12 ppp-cellular.rrd
    -rw-r--r--  1 nobody  wheel  727424 Mar  6 02:12 system-memory.rrd
    -rw-r--r--  1 nobody  wheel  487424 Mar  6 02:12 system-processor.rrd
    -rw-r--r--  1 nobody  wheel  487424 Mar  6 02:12 system-states.rrd
    -rw-r--r--  1 root    wheel    4418 Mar  6 02:12 updaterrd.sh
    -rw-r--r--  1 nobody  wheel  130760 Mar  3 02:09 wan-packets.rrd
    -rw-r--r--  1 nobody  wheel   65672 Mar  3 02:09 wan-quality.rrd
    -rw-r--r--  1 nobody  wheel  521400 Sep  8  2009 wan-queues.rrd
    -rw-r--r--  1 nobody  wheel  521400 Sep  8  2009 wan-queuesdrop.rrd
    -rw-r--r--  1 nobody  wheel  130760 Mar  3 02:09 wan-traffic.rrd

    The permissions seem correct though.



  • @AndrewZ:

    Same here, with the latest snapshot.

    EDIT:
    the issue seems to be gone
    rm /var/db/rrd/*.rrd
    disable/enable RRD graphing backend

    This did the trick for me too.


Log in to reply