Lightsquid "500 - internal server error"



  • Lightsquid on pfSense 2.0-RC1 (amd64) built on Wed Mar 2 12:54:13 EST 2011 doesnt work, i'm getting a 500.

    Doing at console check:

    perl -w `/usr/bin/find / -name check-setup.pl`
    Version string 'f' contains invalid data; ignoring: 'f' at /usr/local/lib/perl5/5.10.1/File/Basename.pm line 51.
    Version string 'f' contains invalid data; ignoring: 'f' at /usr/local/lib/perl5/5.10.1/File/Basename.pm line 51.
    Version string 'f' contains invalid data; ignoring: 'f' at /usr/local/lib/perl5/5.10.1/Exporter.pm line 3.
    Version string 'f' contains invalid data; ignoring: 'f' at /usr/local/lib/perl5/5.10.1/Exporter.pm line 3.
    Feature bundle "0.0.0" is not supported by Perl 5.10.1 at /usr/local/lib/perl5/5.10.1/File/Basename.pm line 51
    BEGIN failed--compilation aborted.
    Compilation failed in require at /usr/local/lib/perl5/5.10.1/Carp.pm line 14.
    Compilation failed in require at /usr/local/lib/perl5/5.10.1/feature.pm line 214.
    BEGIN failed--compilation aborted at /usr/local/lib/perl5/5.10.1/File/Basename.pm line 51.
    BEGIN failed--compilation aborted at /usr/local/lib/perl5/5.10.1/File/Basename.pm line 51.
    Compilation failed in require at /usr/local/www/lightsquid/check-setup.pl line 6.
    BEGIN failed--compilation aborted at /usr/local/www/lightsquid/check-setup.pl line 6.
    
    

    Any hints to repair this?

    I deinstalled lightsquid via pkg_delete, then via gui and installed again with one change: no error 500 appears, only a white page.

    Its (not) working with havp and squidguard. Hope that helps.


  • Rebel Alliance Developer Netgate

    I would pkg_delete squid, perl, lightsquid, etc, and reinstall them all.

    Looks like something in perl isn't right.



  • googling somewhat around i saw this too: some perl-scripts were not available. Did the deinstall/reinstall thing first without luck, but my last snapshot-update and manual reinstall of all packages made the thing.

    To my opinion the automatic reinstall of packages is the culprit. Only manual reinstall helped with nearly all strange errors i had respective to packages. A complete new install of the RC1 didn't help, so its not a broken install (i hope).



  • Same error for me after installing Lightsquid - 500 - Internal Server Error

    I think perl is messed up, as Squidguard seems to cause enough disk thrashing so as to render the firewall / Internet VERY sluggish.  Takes a while, but after uninstalling Squidguard it's OK again.

    How do I reinstall perl?  I thought it was included as a dependency?

    With thanks



  • FWIW - I just fixed this on my 1.2.3 system yesterday by deleting the perl symlink in /usr/bin and running ' ln -s /usr/local/bin/perl /usr/bin/perl ' from the shell.

    My Nokia IP530 sys (packages installed in this order):
    squid
    adzap
    snort (I think the Perl installed with this is the culprit)
    lightsquid
    phpsysinfo



  • Gave it a go, but still seeing a 500 Internal Server Error.  No worries, I plan up upgrading from 1.2.3 RE to 2.0 RC1 shortly.  Thanks though.


Log in to reply