SuperMicro X7SPA-H-D525 with 82574L Dual NIC Issues

  • I'm using the SuperMicro X7SPA-H-D525 Atom server motherboard.  This is a very nice low-power dual NIC board, but I'm having an issue where I will lose WAN connectivity to the cable modem usually after 4-10 hours of activity.  Everything internal works, and I've ruled out the cable modem almost 100% by checking signal levels (meters read that they're as close to ideal as I've ever seen before) and even replaced the new modem with a brand new SB6120 modem.

    What I see:
    Everything appears to be functioning fine before it fails.  The SB6120 front "link" light blinks steadily constantly while the connection is active, (I'm assuming that it's indicating link traffic) but then it will stay solid when the "internet goes out". I'm able to ping the pfsense machine, but unable to ping the cable modem's internal address (  Usually if the cable modem was to drop offline I would still be able to reach that page.
    Both ethernet ports have a real link light on the port itself, both solid.  It seems as though all traffic between the 2 devices just halts.

    What I've done so far:
    Replaced cable modem, replaced cables, updated to 2.0 RC1

    Has anyone seen this type of activity?

  • any chance something is overheating?

  • @mrbostn:

    any chance something is overheating?

    It's very unlikely that the pfSense box is overheating, it has a passively-cooled atom + a 40mm case fan running at full speed 100% of the time (once this is resolved I'm wanting a quieter fan). The processor temp runs steady at about 117˚F in this configuration.

    What I don't think I added before was that it's all happy again when I reset the cable modem, which initially had me replace the modem because I thought it was a sure sign the modem was bad.

  • try swapping interfaces on pfsense…
    If nic01 is lan and nic02 is wan
    Make nic01 wan and nic02 lan

  • Unfortunately, this issue still has not gone away. I may have to ditch pfSense, though I like it. I even replaced the modem again just to be 100% sure. Any other suggestions?

  • Netgate Administrator

    So thus far the only way to recover from loss of WAN is to reset the modem?
    Have you tried (when WAN is down) unplugging and replugging the ethernet cable? Does pfSense show this happening at the console?
    If you reboot pfSense does it come back? (without resetting the modem).

    It could be a power management option putting the NIC to sleep. Try disabling all the power management in the bios.  There are loads of other people running the same NICs with no problems. Try putting a switch between your pfSense box and the cable modem if you have one to hand.


  • Your suggestion of power management sent me in the right direction.  I went through the BIOS and noticed that the ACPI settings were changed from default to ACPI v3, I set it back to v2 and I have not seen a hiccup in almost 3 days.  Thanks for the suggestion!

  • It seems like it was just playing with me, just this morning it happened again.  It definitely took longer for it to happen with ACPI v2 than with v3.  Is it a bad idea to disable ACPI completely within the BIOS?

  • Netgate Administrator

    Nope that's the first thing I'd try.
    By disabling acpi you may have trouble with some hardware power features such as shutting down but it shouldn't be a problem for normal use.
    Whoever wrote the bios on my box didn't bother to create the acpi tables correctly and consequently it won't boot at all with acpi enabled.


  • I have exact the same board and no probs with the LAN/WAN. I even have ACPI v3 enabled in the bios. But which bios-version do you have installed? I have had lots of problems with the "old" bios, which was 2.0.1. Now i have a 2.2.0 (some strange things happen, but not respected to the nics) and 2.2.3 here, which is beta. I still didnt install the 2.2.3 because its beta-firmware. At the supermicro-website you only get the old bios-file. Maybe that helps.

  • I only see the 1.1a bios on their support site, which is what shipped on the board.

Log in to reply