Create WAN rule from template doesn't match (possible GUI bug)



  • I used the wizard to create an OpenVPN server. It automatically creates a WAN rule allowing UDP traffic to 1194, as it should. However, when I click the plus sign to the right of this rule to add another similar rule (to another interface in this case), the new "template" rule for me to edit and save has UDP selected as the protocol rather than UDP as the original rule had. I haven't had time to test this more extensively, and I can manually change it, but I expected the new rule to be an exact duplicate of the one I used as a template and thus almost didn't catch the change, which would have been frustrating when it didn't work :-) A minor niggle perhaps, but it's an RC, it's time for that (and I've never noticed this problem before). Snap is 2.0-RC1 (i386) built on Wed Mar 2 08:19:30 EST 2011

    I just tried this on 2.0-RC1 (i386) built on Wed Mar 2 04:03:59 EST 2011 as well on a different box (both are embedded though) and have the same issue. There are other UDP WAN rules however, and all of them work fine keeping UDP set when using "add new rule based on this one" except for the OpenVPN rule created by the wizard, which still switches to TCP automagically (black magic! :-)


  • Rebel Alliance Developer Netgate

    waves a magic wand
    Abracadabra, alakazam
    poof
    https://rcs.pfsense.org/projects/pfsense/repos/mainline/commits/6be90004d477bd74c5610ae341aae3ae9fcc9281
    The bug has disappeared…

    (of course someone would have to run the wizard again to pick up the corrected rule...)



  • Awesome :-) I assume that I can just edit the config.xml file and re-upload it to use lowercase for that rule and avoid re-running the wizard? Not that I care terribly much. Heck, I can just delete the NAT rule altogether and recreate it from scratch :-) Heck the only reason I run the wizard is so I don't forget to add the NAT rule manually anyway…


  • Rebel Alliance Developer Netgate

    Or just edit the rule, set to UDP again, and save. Nothing fancy needed.



  • Oh yeah…duh. Too early for me, brain no worky yet :-) Thanks Jim, you still rock (as always)!


Log in to reply