Can't boot after config restore to the new box 2.0-RC1(i386) to 2.0-RC1(AMD64)



  • Hello, i have an old P4 with:
    2.0-RC1  (i386)
    built on Thu Mar 3 10:56:18 EST 2011

    correctly updated with the auto updater.

    Now i have a new hp proliant microserver to excange with the old p4. I have installed pfsense 2.0-RC1  (AMD64) coz is an amd 2 cpu and all work fine, i access the web config, i can reboot etc. When i try to restore the old p4 xml config file the loading work fine, i see all changes and config loaded but when i reboot the box it don't start anymore. Just a blink cursor:

    some idea? Thanks



  • i have try  differtent snapshots, same problem. The clean installation seem unstable too, maybe some hardware incompatibility?



  • Definitelly i can say its a problem of RC1 relese, on the hp proliant microserver (dual core cpu) if i install this version:

    pfSense-2.0-BETA5-i386-20110215-1537.iso.gz

    all work good, i can restore other server config and the system work great. If i clean install RC1 or if i upgrade to RC1 with the auto updater in the web GUI i get the blink cursor on reboot. If someone need other hardware specifications im available for find the bug that im sure exist in the RC1 and not in the BETA5.

    Thanks



  • i think its the boot loader.  I could not upgrade from a pfsense 1.2.3, and could not install from rc1 cd.

    i booted a recovery disk, and zero'd out the first 512 bytes (ymmv)

    if you don't know how to do this, I am not going to tell you because you will muck up your hd.

    (but it worked for me)



  • Yes if you can explain me how to fix that would be great. I think its a problem of the boot loader too because the system can't start anymore! Thanks mate for your help!



  • I have solved the problem with these steps:

    • Run pfSense 2.0 RC1 without install it but in Live mode from usb cd

    • restore config xml from the webgui but

    • when the webgui ask for interfaces remapping don't press apply (this avoid the reboot) just press SAVE button in the bottom of interfaces

    • now the backupped config is loaded without reboot

    • from the firewall console (with a monitor attached on the firewall box) type 99 for install using the loaded config file

    These steps worked for me and all is working, the old config and the boot after reboot. Im sure that this RC1 have some bug when normal load config file from webgui. Its something related with the bootloader. I hope some pfsense programmer will take a look for fix this problems because atm for example i can't UPDATE via webgui or the boot fuck up.

    Regards


Log in to reply