Problem with DHCP leases status from snapshot 07-01-2007



  • Greetings,

    i have a problem … i updated to snapshot 07.01.2007 and after this update i dont see any dhcp leases in dhcp leases status (only static adress)
    I tried upgrade to lastest snapshot 13.01.2007 but dhcp leases status had same problem.

    When i downgrade to snapshot 12-28-2006 dhcp status work fine !



  • I can confirm the same problem, exactly as stated.



  • Would you mind pasting parts of the dhcpd.leases file from /var/db/dhcpd/var/db/dhcpd.leases

    
    # ls -l /var/dhcpd/var/db/dhcpd.leases
    -rw-r--r--  1 root  _dhcp  466 Jan 15 21:27 /var/dhcpd/var/db/dhcpd.leases
    
    

    and

    
    # more /var/dhcpd/var/db/dhcpd.leases
    # more /var/dhcpd/var/db/dhcpd.leases
    # All times in this file are in UTC (GMT), not your local timezone.   This is
    # not a bug, so please don't ask about it.   There is no portable way to
    
    

    I would very much like to see what it looks like. I have a hunch, but I am not sure. I have rewritten this page because it was very slow and I think I might forgotten a case. But I need a working dhcpd.leases example for this.



  • Fixed in CVS



  • In case you did not catch all of the problem with the DHCP status page.
    The "hostname" entries for the dynamically allocated IPs are missing from the Status page.

    One of the entries in the DHCPD.leases file for the
    1.0.1-SNAPSHOT-01-13-2007 built on Thu Jan 18 00:33:06 EST 2007

    lease 192.168.1.179 {
      starts 4 2007/01/18 07:09:10;
      ends 4 2007/01/18 09:09:10;
      tstp 4 2007/01/18 09:09:10;
      binding state active;
      next binding state free;
      hardware ethernet 00:07:95:xx:xx:xx;
    }

    The /etc/hosts file does not contain a corresponding IP hostname entry.



  • if the dhcpd.leases file does not contain the client-hostname field I can not show it on the status page either.

    I have a lot of dynamically connected clients here and those hostnames are shown normally.



  • Thanks databeestje,
    It appears that WinXp DHCP Clients send the hostname to the DHCP server an it logs

    lease 192.168.1.176 {
      starts 4 2007/01/18 17:42:27;
      ends 4 2007/01/18 19:42:27;
      binding state active;
      next binding state free;
      hardware ethernet 00:0b:xx:xx:xx:xx;
      uid "\xxx\xxx\xxx\xxx\xxxxx";
      client-hostname "Calico";
    }

    whereas the Ubuntu 6.10 release dhcp3 client does not send its hostname to the pfsense DHCP server unless;

    send host-name "ServerName"

    is added to the /etc/dhcp3/dhclient.conf file.

    "ServerName" must be specified manually since hostname does not pipe through.

    is there a better way?

    Please note that the "ServerName" does not appear in the Edit static mappings Hostname entry Box



  • There is a dhcp server knob to register dhcp hostnames in the DNS server.

    But that still requires the client to send the hostname.

    It's issue with Ubuntu, take it up with them. Knoppix and grml do send (generated) hostnames to the dhcp server.



  • Both
    Register DHCP leases in DNS forwarder
    Register DHCP static mappings in DNS forwarder
    are enabled.

    Version 1.0.1 transfered the hostname from the dynamic Hostname entry to the
    Edit static mappings Hostname entry Box. Current version does not. If that is the way it is supposed to work ok.

    Issues with Ubuntu were just a reference for others with the same problem.
    Thanks again



  • @Vescovo:

    Both
    Register DHCP leases in DNS forwarder
    Register DHCP static mappings in DNS forwarder
    are enabled.

    Version 1.0.1 transfered the hostname from the dynamic Hostname entry to the
    Edit static mappings Hostname entry Box. Current version does not. If that is the way it is supposed to work ok.

    Issues with Ubuntu were just a reference for others with the same problem.
    Thanks again

    I have corrected the issue of the hostname not being transfered to the edit static mappings hostname field. This fix should appear in a snapshot in the next few days.



  • thanks rsw686


Log in to reply