Verizon LG VL600 4G/3G Modem help request

  • My father is stuck on satellite internet with abysmally bad service (WildBlue).  After he was throttled to 8KB/3KB for a month due to using more than 2GB of traffic in a month, I set him up with pfSense on an Alix box so he could monitor his usage.

    He has no other internet service providers available to him, but fantastic cell reception due to a close by tower with excellent 3G coverage.  He wanted to try the 3G as his sole internet connection, as he only uses 2-3GB/mo at the most.  Verizon has stopped selling any regular 3G modems, and they only offer 4G LTE models now, that are backwards compatible with the 3G network.  He bought an LG VL-600, and we followed the instructions to set up the PPP connection as his WAN.  The device was detected with no problems (no modeswitch needed), but he does not receive an IP address.  Under System Logs -> PPP, it states "Chat script failed" and "AT command not accepted".  I'm supporting him from 800 miles away, so I don't have direct access to his system.

    Can anyone help me get this LG VL-600 USB 3G/4G modem working?  Thanks very much for any assistance anyone can provide!

    Edit:  Should add that this is on pfSense 2.0RC1 4Mar2011

  • These devices often present multiple serial ports under /dev/ (like /dev/cuaU0.0, cuaU0.1, etc.).

    If you select the wrong one, the modem won't connect, likely as you've described.

    Send the output of
    ls -al /dev/

    and your config.xml file (from Diagnostics -> Backup /Restore GUI menu).


  • Ah, great, that does sound like a likely suspect.  I'll get that from him in the morning and post back.  So far, only that one device was presented as an option in the PPP dialog, if that matters.

  • pfsense does a cursory check on the ports it lists to make sure that they respond to an initial 'AT' query. So your port might be a control port that responds to 'AT' but isn't actually the modem port.

    I saw someone on ubuntu forums having problems with this device too.

    I'd try ebay for one of the 3G modems supported by pfsense. I use the Sierra Wireless C885 on a GSM network. There's a list of supported 3G modems on the pfsense wiki.

    Once you get this working your dad will be very happy with the switch away from satellite. :)


  • the pantech is more *nix friendly, and there are sample configs to get that to work. (*nix, not pfsense) but should work in at least fsense 2.0.
    and/or there are a couple inexpensive 4g/ routers that use it also.

    (and I have a usb 3g card I don't need.. but go for 4g if its available.
    example:  3g plan:  $60 a month, 5GB max, $1 per megabyte after.
    4g plan:  $50 a month, 5GB max, $10 per gb after.

    and, believe me, the speed is great.

  • Well, 6+ hours on the phone, and we've reached the conclusion that neither the Pantech nor the LG are particularly "ready to go".  I manually had him change the /dev/cu* devices around, and when looking through the logs, it looked like it was nearly there (Hayes compatible modem found, unable to establish connection).  After finding a nasty little bug where we would change his WAN from DHCP on VR1 to the PPP connection, and then back, and upon reboot, the pfSense install would not reboot successfully with a kernel panic.  We re-imaged his CF card several times getting around this.

    In the end, I'm having him buy a Cradlepoint CTR35 device which claims to support the Pantech 4G modem natively, and we can provide the connection to VR1 on the pfSense as his main WAN.

    Thanks for the pointers and the assistance, I really appreciate it.  For future searches, I would say that the Pantech and LG 4G LTE modems do not work out of the box as a PPP connection with pfSense 2.0RC1. See next post.

  • New information:  The Cradlepoint CTR35 doesn't support the Pantech UML290 in 3G mode right now, either, due to something on Verizon's end about switching back and forth between 4G and 3G modes.

    I was able to get this LTE modem to work easily and immediately by visiting this link: and obtaining the little software tool for Windows to manually set "3G Only" mode on the modem's firmware.  After that, pfSense used it quite easily.  This was preferable for him to buying an older, known-working model, as to get their new data plan with $10/GB overage charges instead of the huge 3G overage charges, you have to purchase LTE equipment.

    The only problem we're experiencing is that the connection is significantly faster when using Verizon's software to connect to the network, rather than pfSense natively or the Cradlepoint (if anyone has any ideas on settings I could modify to fix this, I'd love to test it).  On Verizon's software, he gets 1.8Mb/.9Mb, whereas with pfSense or the Cradlepoint with the latest firmware he's getting 1.0Mb/.1Mb.  I've tried having him adjust the MTU, but that seems to simply make it worse.

    In any event, the Pantech UML290 works just fine with pfSense 2.0RC1 after having the modem firmware switched to 3G only mode.

  • The only problem we're experiencing is that the connection is significantly faster when using Verizon's software to connect to the network, rather than pfSense natively or the Cradlepoint (if anyone has any ideas on settings I could modify to fix this, I'd love to test it).

    It's interesting that you say this, because I use a 3G modem on an EDGE network, which is already very slow, but users report that the access is slower through pfsense vs. just directly accessing the EDGE network from their iPhone. I have no idea why.


  • Rebel Alliance Developer Netgate

    Hard to say what might be at work there but you could do some packet captures and see if you are seeing things like retransmits and such.

    The easiest thing is to is to try tinkering with the MTU to see if that gains you any speed.

  • I tried having him adjust the MTU several times to no (good) effect.  Looking at a packet capture, everything seemed okay.  I also tried manually creating the <speed>entry under the PPP section of config.xml, just to see if that might have an effect.

    In the end, he only had 12 days to check it out before he would be locked into a contract for the device, so we gave up on it.  Satellite internet was actually substantially faster throughput than the Pantech through pfSense or the Cradlepoint device.  :-\

    Thanks for checking in on this topic, jimp.  I really hope you guys have a 2.0 book planned … the first one was very helpful.</speed>

Log in to reply