PfSense 2.0-RC1 Snort and other servicesa error.



  • Hello dear,
    I m have using 2.0-RC1 (amd64) built on Fri Mar 4 11:03:45 EST 2011

    My Snort Package installed but services are not start!

    I will try to start shell and take it this error:

    
    [2.0-RC1][root@pfsense.hbglobal.local]/root(3): snort
    Running in IDS mode
    
           --== Initializing Snort ==--
    Initializing Output Plugins!
    Initializing Preprocessors!
    Initializing Plug-ins!
    Parsing Rules file "/usr/local/etc/snort/snort.conf"
    PortVar 'HTTP_PORTS' defined :  [ 80 311 591 593 901 1220 1414 1830 2301 2381 2809 3128 3702 5250 7001 7777 7779 8000 8008 8028 8080 8088 8118 8123 8180:8181 8243 8280 8888 9090:9091 9443 9999 11371 ]
    PortVar 'SHELLCODE_PORTS' defined :  [ 0:79 81:65535 ]
    PortVar 'ORACLE_PORTS' defined :  [ 1024:65535 ]
    PortVar 'SSH_PORTS' defined :  [ 22 ]
    Detection:
       Search-Method = AC-Full-Q
        Split Any/Any group = enabled
        Search-Method-Optimizations = enabled
        Maximum pattern length = 20
    ERROR: parser.c(5165) Could not stat dynamic module path "/usr/local/lib/snort_dynamicpreprocessor/": No such file or directory.
    Fatal Error, Quitting..
    

    So i try to change /usr/local/etc/snort/snort.conf
    I will check thats folder is in "/usr/local/lib/snort/dynamicpreprocessor/
    and others same change to config file.
    Later i take rule file error.

    [[b]2.0-RC1][root@pfsense.hbglobal.local]/root(5): snort
    Running in IDS mode

            --== Initializing Snort ==--
    Initializing Output Plugins!
    Initializing Preprocessors!
    Initializing Plug-ins!
    Parsing Rules file "/usr/local/etc/snort/snort.conf"
    PortVar 'HTTP_PORTS' defined :  [ 80 311 591 593 901 1220 1414 1830 2301 2381 2809 3128 3702 5250 7001 7777 7779 8000 8008 8028 8080 8088 8118 8123 8180:8181 8243 8280 8888 9090:9091 9443 9999 11371 ]
    PortVar 'SHELLCODE_PORTS' defined :  [ 0:79 81:65535 ]
    PortVar 'ORACLE_PORTS' defined :  [ 1024:65535 ]
    PortVar 'SSH_PORTS' defined :  [ 22 ]
    Detection:
       Search-Method = AC-Full-Q
        Split Any/Any group = enabled
        Search-Method-Optimizations = enabled
        Maximum pattern length = 20
    ERROR: Unable to open rules file "/usr/local/etc/snort/../rules/local.rules": No such file or directory.
    

    I will change in conf file
    var RULE_PATH rules
    and check the rules file /usr/local/etc/snort/rules/
    all files have snort_local.rules
                    snort_chat.rules
                    snort_*.rules etc.

    I m add to conf file all rules start snort_*.rules
    Later try again to start Snort:

    [b]    Reassembly Ports:
          21 client (Footprint)
          22 client (Footprint)
          23 client (Footprint)
          25 client (Footprint)
          42 client (Footprint)
          53 client (Footprint)
          79 client (Footprint)
          80 client (Footprint) server (Footprint)
          109 client (Footprint)
          110 client (Footprint)
          111 client (Footprint)
          113 client (Footprint)
          119 client (Footprint)
          135 client (Footprint)
          136 client (Footprint)
          137 client (Footprint)
          139 client (Footprint)
          143 client (Footprint)
          161 client (Footprint)
          311 client (Footprint) server (Footprint)
    Stream5 UDP Policy config:
        Timeout: 180 seconds
    ERROR: /usr/local/etc/snort/snort.conf(194) => Invalid keyword 'compress_depth' for 'global' configuration.
    Fatal Error, Quitting..[/b]
    

    I will check thats error on Snort forums, I Found this one SOLVE but not work for pfSense;

    in the source dir i did:
    make clean
    make uninstall

    after a ran again ./configure —enable-zlib —with-mysql
    make
    make check
    make install

    now work for me!

    How to resolve thats package problem?

    So, NTOP 4.0 have same problem, i will try gui install, i will try shell install pkg_add -r ntop etc.
    Service NOT start any time.



  • Issue is /usr/local/etc/snort.conf

    File gets auto created when rules are updated. Not sure why the file is configured all wrong.

    Till recently you used to be able to just copy the snort.conf file from snort_*_ folder in the same directory and overwrite the other one. That fix no longer works.

    Not sure where to head now… Hope this helps a little.

    Anyway, it looks like the package is going through a major overhaul. Perhaps the best thing to do is just wait till the new version is released.



  • Hi,
    EDIT: please see my post here > http://forum.pfsense.org/index.php/topic,37452.0.html. NOt sure if it is even the same issue; however, its worth a shot.

    I confirm this issue with:

    snort > 2.8.6.1 pkg v. 1.35
    pfsense 2.0 build > 2.0-RC2 (i386) built on Wed Jun 1 12:43:15 EDT 2011

    I am unable to see which rules are running. Snort.org : N/A even though I get an alert that my rules are up to date.

    Oddly, it was working on Jun 3.


Log in to reply