RRD Graphs not working



  • i updated my box from 1.2.3 to 2.0 rc1 and my graphs where dead. i was getting this error.

    php: /status_rrd_graph_img.php: Failed to create graph with error code 1, the error is: ERROR: This RRD was created on other architecture/usr/bin/nice -n20 /usr/local/bin/rrdtool graph /tmp/system-processor.rrd-4year.png --start 1173026949 --end 1299516549 --vertical-label "utilization, number" --color SHADEA#eeeeee --color SHADEB#eeeeee --title "`hostname` - System :: Processor - 4 years - 1 day average" --height 200 --width 620 DEF:"user=/var/db/rrd/system-processor.rrd:user:AVERAGE" DEF:"nice=/var/db/rrd/system-processor.rrd:nice:AVERAGE" DEF:"system=/var/db/rrd/system-processor.rrd:system:AVERAGE" DEF:"interrupt=/var/db/rrd/system-processor.rrd:interrupt:AVERAGE" DEF:"processes=/var/db/rrd/system-processor.rrd:processes:AVERAGE" AREA:"user#990000:user" AREA:"nice#a83c3c:nice:STACK" AREA:"system#b36666:system:STACK" AREA:"interrupt#bd9090:interrupt:STACK" LINE2:"processes#cccccc:processes" COMMENT:"\n" COMMENT:" minimum average maximum current\n" COMMENT:"Use
    

    when i searched around i read this. i tried it with the command in the webgui. it didn't work. i didn't know if i needed to do it via ssh. or if something else was wrong. i did update from a 32bit to a 64 bit i don't need to keep my old graphs if i cant that's fine.

    @jimp:

    @itsmorefun:

    Aug 2 16:33:24 php: /status_rrd_graph_img.php: Failed to create graph with error code 1, the error is: ERROR: This RRD was created on other architecture

    Did you switch between 32 and 64-bit releases? You may just need to rm /var/db/rrd/* and then re-save on the RRD settings.


Log in to reply