PPTP VPN PassThrough? Connections Dropping?

  • After trying 2.0 Beta and finding it unstable for our use.
    I have been running 1.2.3 with no problems, but needed to tweek the multi-wan load balance, so a few days ago I upgraded 1.2.3 to the 2.0 RC snapshot.
    Currently running 2.0-RC1 (i386)
    built on Mon Mar 7 12:03:17 EST 2011

    Now all incoming PPTP VPN connections that go to a internal Windows server drop after a few minutes.

    I have try manually setting up the NAT and Rules, Using the PPTP redirect and both together.

    I have removed all multi WAN settings and still the connections drop

    Could any one help me on this as I have a large number of remote users saying they cannot get connected.

    All worked fine on the Beta and 1.2.3

    testing this morning with i get the message "the server stopped responding" the server has not stopped responing though

    I have now tried this on 2 of my wan connections with the same problem.

    I suppose the question is, does PPTP VPN Passthrough work on the current RC?

    This was a auto upgarade from 1.2.3 to 2.0RC, should I try a new install?

    Thanks in advance

  • Rebel Alliance Developer Netgate

    There is an issue with the PPTP proxy code that can result in GRE states timing out before the tcp/1723 state does. It's a known issue.

    You can try disabling the pptp proxy (check the system tunables under System > Advanced, set debug.pfpptpproxy to 1)

  • FYI - setting debug.pfpptpproxy to 1 will prevent any outgoing PPTP connections if you have the PPTP server enabled.


Log in to reply