Changing WAN Interface to 10Mbps Full Duplex



  • Hi,

    I just want to know how to change the interface to full duplex in pfsense 2.0 RC1 right now it is showing 10Mbps / Half Duplex.

    Thanks.



  • By the way my network card is capable of having full duplex, as I was able to change it and make it working as full duplex before using version 1.2.3 release. Now when I am trying to change the config.xml the setting does not work anymore.

    Thanks.


  • Netgate Administrator

    What sort of NIC is it?
    What is it connected to?

    Steve



  • It is an onboard network card in a dell poweredge server 10/100/1000, it is connected to the manage switch we have configured as 10Mbps Full Duplex.


  • Netgate Administrator

    Ok, so what driver is it using, what does the interface come up as? em0?

    Steve



  • Yes it comes up with em0. I did changed and add the following settings in the config.xml but still showing as half duplex in the dashboard.

    <media>10baseT/UTP</media>
    <mediaopt>full-duplex</mediaopt>
    <bandwidth>10</bandwidth>
    <bandwidthtype>Mb</bandwidthtype>



  • Did you edit on the fly, or edit offline and restore the config? If you edited the config using diagnostics, edit file you will need to reboot. Alternatively, you could use the shell or diagnostics, command to set it- ifconfig em0 media 10baseT/UP mediaopt full-duplex



  • I edit it through secure shell, I login on the secure shell and edit the config.xml, I will try your suggestion.

    Thank you.



  • I tried to use "ifconfig em0 media 10baseT/UP mediaopt full-duplex" in secure shell but I got this message "ifconfig:unknown media subtype: 10baseT/UP".

    Any suggestion would be greatly appreciated.

    Thanks.



  • My typo, sorry.
    10baseT/UTP



  • Thank you, after trying the command I did reboot the pfsense and still no luck still showing as 10Mbps Half-Duplex in the dashboard. Is there a way to verify in the shell if the wan interface is set to full-duplex? I am thinking maybe the dashboard is not showing the proper media interface mode.


  • Netgate Administrator

    if you enter:

    
    [root@fire.box]/root(6): ifconfig em0
    em0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=9b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum>ether 00:90:7f:31:4b:f0
            inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255
            inet6 fe80::290:7fff:fe31:4bf0%em0 prefixlen 64 scopeid 0x1
            media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active</full-duplex></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum></up,broadcast,running,simplex,multicast> 
    

    You should see the current mode.

    Also adding -m will show all possible modes:

    
    [root@fire.box]/root(16): ifconfig -m em0
    em0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=9b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum>capabilities=1db <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,polling,vlan_hwcsum,tso4>ether 00:90:7f:31:4b:f0
            inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255
            inet6 fe80::290:7fff:fe31:4bf0%em0 prefixlen 64 scopeid 0x1
            media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active
            supported media:
                    media autoselect
                    media 1000baseTX
                    media 1000baseTX mediaopt full-duplex
                    media 100baseTX mediaopt full-duplex
                    media 100baseTX
                    media 10baseT/UTP mediaopt full-duplex
                    media 10baseT/UTP</full-duplex></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,polling,vlan_hwcsum,tso4></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum></up,broadcast,running,simplex,multicast> 
    

    Steve



  • This is my result when I did an ifconfig of em0:

    ifconfig em0
    em0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=9b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum>ether 00:06:5b:ec:b5:28
            inet 192.168.100.1 netmask 0xffffffe0 broadcast
            inet6 fe80::206:5bff:feec:b528%em0 prefixlen 64 scopeid 0x1
            nd6 options=3 <performnud,accept_rtadv>media: Ethernet 10baseT/UTP <full-duplex>(10baseT/UTP <half-duplex>)
            status: active

    By the way I did edit the config.xml under diagnostic>edit file with this:

    <media>10baseT/UTP <media><mediaopt>full-duplex <mediaopt></mediaopt></mediaopt></media></media></half-duplex></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum></up,broadcast,running,simplex,multicast>



  • It still showing as half-duplex in the dashboard.



  • The output shows that it is set for full-duplex, but it's running in half-duplex. I would encourage you to verify the switch configuration, patch cables, etc.



  • I checked the manage switch we have and it is actually set to Full Duplex in all ports, also I have two pfsense the other one is currently working as my primary firewall and it is actually shows as full duplex. I tried to unplug the primary wan network cable and put it on my new pfsense 2.0 RC1 just to checked it the port in my switch have problem but it still showing as half duplex.

    Anyway, even though it is showing as half-duplex in the dashboard after I've edited the config.xml and set the media interface mode to full duplex manually it is working as it is supposed to be, I am now getting the correct internet bandwidth as compare before when the media interface is not define although it still showing as half-duplex in the dashboard.

    So I will just let the way it is as it is working now.

    Thanks.


  • Netgate Administrator

    Hmm,
    Well the dashboard is agreeing with ifconfig that the interface is still running half duplex.
    There seem to be a few people having trouble with the em(4) driver and 2.0RC at the moment. It's interesting though that you report the speed does seem to have increased. Perhaps it is an error with the reported status. I'd be interested in your output from the command: sysctrl dev.em.0.%desc

    Here's mine under 1.2.3

    
    [1.2.3-RELEASE] 
    [root@fire.box]/root(3): sysctl dev.em.0.%desc
    dev.em.0.%desc: Intel(R) PRO/1000 Network Connection 6.9.6
    
    

    Are both your boxes the same hardware? How does the above command result vary?

    Steve



  • First thank you for the prompt reply on this issue, here are the interface driver of em0 for both firewalls:

    [Release 1.2.3]
    sysctl dev.em.0.%desc
    dev.em.0.%desc: Intel(R) PRO/1000 Network Connection 6.9.6

    [Release 2.0 RC1)
    sysctl dev.em.0.%desc
    dev.em.0.%desc: Intel(R) PRO/1000 Legacy Network Connection 1.0.3


Log in to reply