2.0RC1: Stuck with interface mismatch after upgrade



  • Hi,

    there is a post relating to this already. After upgrading to 2.0RC1 I get an interface mismach and are stuck there; it will repeat over gain. I get the following errors; can't see all though (and there is no copy/paste :) - but most are from /etc/inc/config.console.inc

    Warining: Cannot use a scalar value as an array in /etc/inc/config.console.inc on line 485
    

    I upgraded from 1.2.3release i386 uniprocessor kernel to 2.0 RC1
    I reverted the VM I am using and removed all VLANs and interfaces - same.

    (I have a prepped config.xml but dont want to post it here)

    Thx, Helge



  • Saw that as well before I downgraded back to the March 2nd RC1.

    If you screen capture right before that error pops up the text is complaining that the config file is newer than the pfSense version (not an exact quote but something to that effect).  I reset to factory defaults, copied the config, cut and paste by section my old config settings (carefully) into the factory default config, restored and all was well again.

    Might have something to do with the pfsense version number at the very top of the config file.


  • Rebel Alliance Developer Netgate

    If you don't mind sharing your 1.2.3 config.xml I can look it over.

    The usual cause of such an error is a problem in the original config, such as international characters in a place that causes invalid xml.




  • Rebel Alliance Developer Netgate

    That's only in the ipv6 branch. I'm not sure if that would affect anyone else.

    Probably not related to this.



  • First of all thank you guys and big sorry, had to work on other things - took a while to answer …

    The problem is - of course - the config.xml.
    I made a new VM with a clean RC1 on it. First I thought it was not possible to restore a 1.2.3 config to 2.0RC1. I run into an error when I tried. I also tried to restore the conf section by section - no error but nothing was restored as well.

    After I removed the following things from my conf (thx onhel) - then it worked:

    <version>3.0</version>
    <lastchange><theme>pfsense_ng</theme>
    (system)
           <optimization>normal</optimization>

    and fixing the interfaces (other dev names in the VM) and removing the packages I could restore the config. But when I boot up I get the following:

    Fatal error: Call undefined function upgrade_000_to_001() in /etc/inc/config.lib.inc on line 405

    Of course I can't post the hole config.xml here - it took me a while to wipe it of all personal data. I use a lot of certs here though (open vpn PKI, SSL certs for the machine, SSH keys, RADIUS auth keys) witch I replaced with XXX and so on. There is also a snort config witch I keep for sentimental reasons; but no snort installed and running (never got to to work properly).

    Sorry, very long thing.

    Its to big and got truncated, I put it here:
    http://files.m-box.de/DOWNLOAD/HELGE/config-pizzabox-test.mbox.loc-20110308195725.xml

    (please use save link as :)

    Thanks,
    helge</lastchange>


  • Rebel Alliance Developer Netgate

    You need that version tag, and the others aren't hurting it either.

    Your problem is this:

    <descr>SSH Zugang von außen</descr>
    

    Get rid of the ß and it will parse correctly.



  • @jimp:

    Get rid of the ß and it will parse correctly.

    Hi jim,

    did that - they seemed to have skipped my attation as I was using the wrong encoding while viewing the file… thanks for your attention!

    That said - its sill not working. First time I uploaded the conf I was getting a very promising "convert config" message - after one hour of no change I just ctrl-c'ed it. After a reboot I end up with losts of errors from the RRD converter and no configuration at all.


  • Rebel Alliance Developer Netgate

    Hmm, I haven't seen that happen before on anything I've done with a config restore/upgrade.

    Was this from a fresh install, or over the top of a setup that you tried to restore previously?

    It might be worth trying to wipe it and restore the config again.



  • Hi jim,

    I'm testing this all the time in a VM and rolling back the snapshots - so I am always trying this from a "fresh install" if you want to say so.

    The original config of course evolved over time; but I started with 1.2.3 - so no version change or rewritten config.


  • Rebel Alliance Developer Netgate

    What are you rolling back to in the VM? 1.2.3 or a fresh 2.0-RC install?



  • To the fresh 2.0RC1 of course - the conf.xml is 1.2.3


  • Rebel Alliance Developer Netgate

    Have you tried only removing the <installedpackages>section of the config and then restoring it?</installedpackages>



  • Yes, tried it with and without packages.


  • Rebel Alliance Developer Netgate

    OK, earlier you said you tried that but you also removed the config version tag at the same time, which would have given you that upgrade error.

    Just to be clear, did you try it without packages (and no other changes) or were you referring to the time you tried it that you mentioned in the original post?



  • Hi jim,

    you where right! I removed the packages manually and maybe I forgot something. Today I started with a clean download. Seemed to work at fist glance - but at least the PPPoE config / VLAN Config / OpenVPN did not import.

    But now I can start testing it at least ;)


Log in to reply