Connections keeps dropping



  • Prior to upgrading to 2.0RC1 from 2.0Beta5, I was able to maintain a stable OpenVPN connections to 2 1.2.3 pfsense firewalls. Now is seems to get stuck with this in the logs:

    Mar 8 17:15:54 openvpn[46639]: write UDPv4: No buffer space available (code=55)
    Mar 8 16:59:19 openvpn[46639]: write UDPv4: No buffer space available (code=55)

    Any ideas on what to do to correct this issue?

    Podilarius

    <edit>Seems to happen on any long connection. I have started 3 rather large FTP and the system drops the connection periodically.
    Found this in the log also.

    Mar 8 18:20:43 apinger: alarm canceled: WAN(151.213.12.135) *** down ***
    Mar 8 23:20:42 check_reload_status: reloading filter
    Mar 8 18:20:32 apinger: ALARM: WAN(151.213.12.135) *** down ***

    It is very strange to see time out of place also. Wonder if that has something to do with the connection drops.</edit>



  • @podilarius:

    It is very strange to see time out of place also. Wonder if that has something to do with the connection drops.

    I've seen similar time non-linearities in my logs. I wonder if it was just chance that the time difference I observed was equal to the offset from UTC to local time.



  • I am wondering if that jump in time tries to remove stale states that are actually active states.



  • Does not look that way as I went back to a previous build on March 1 at 23:xx and I still have OpenVPN issue.
    I still get:

    openvpn[38096]: write UDPv4: No buffer space available (code=55)

    Does anyone know when the last update to OpenVPN was so that I can go back prior to the changes and re-test?

    I am also seeing sustained FTP download loosing connection, but to be fair the other side is an up-to-date pfsense outside of my control. Going to test with DVD download soon.

    Podilarius.


Log in to reply