Problem with RTL8169S/8110S/8211B media interface . PHY write failed

  • Hi,

    I have a problem with NIC re0 RTL8169S/8110S/8211B. At /var/log/system.log I see "kernel: re0: PHY write failed"
    and "gateway kernel: re0: reset never completed!" errors. The solution is to reboot the pfsense, and NIC works fine during 1 or 2 hours and then goes bad again. I've tried to configure NIC to WAN or LAN but error is the same at both.

    Reading some post on the web, FreeBSD SO have some problems with this type of NICs, in versions 7.0 and 8.0. I'm on this one:

    FreeBSD gateway.xxxxx.local 8.1-RELEASE-p2 FreeBSD 8.1-RELEASE-p2 #1: Tue Mar  8 15:59:09 EST 2011  amd64

    I've been updating my psfsense daily. I've not tried to insert drivers because I'm newbe on FreeBSD.

    Some ideas? some help?

    Thanks a lot.

  • Rebel Alliance Developer Netgate

    Either it's a hardware issue or a driver bug, either way the Realtek brand isn't usually known for quality. I haven't had any issues with the re(4) NICs myself, but if you have any other card to swap that with as a test, it would be worth trying.

  • I'm still on the issue. I don't have any other network card to put on it. I've been keeping on date all the new releases of the version of my pfsense machine, but there is no solution yet, only way is to reboot the machine.

    It's OK that problem is a driver bug, is there any way to report to developers to solve it?

    Internet forums tell that there are patches to resolve this on FreeBSD OS, but I don't now how to put this one on a pfsense machine.

    Thanks jimp for your response.

Log in to reply