Cannot upgrade from 1.2.3 to 2.0rc1 on alix board.



  • When i tried to update from 1.2.3 on an alix board the 2.0rc1 boots up and then asks which interfaces i wish to assign.  When i choose them it complains about scalar array problems with the config and cycles.  I have booted into the 1.2.3 partition.

    My config is below.  I have an arthos wireless card in it.

    This is my home network setup so i am happy to try any changed upgrades you have and leave this running off the second partition as a test case.

    I have a few pfsense out there in customer sites so getting upgrade working would be nice.

    I am sure i have stripped all passwords and public identity from the config but feel free to strip it if anythings left :)

    EDIT.  Cant seem to paste my whole config.  Max post size?  let me know if / how you want me to get you the config.



  • Be sure to strip special characters like ÖÄÜ etc.!

    http://forum.pfsense.org/index.php?topic=33790.0



  • I've had the same issue with most of my ALIX routers also, 6 or 7 of them.  None of my config info upgrades properly.  What I've started doing is just backing up the config and dd'ing the full embedded rc1 image to the CF, then reconfiguring manually.  It was the only sure way I knew everything was working.


Log in to reply