Upgrading to 2.0: The Ups and Downs



  • So I just finished upgrading to 2.0. It took over 2 hours, and was not a pleasant experience. I ended up in an endless loop of Interface Mismatch. After a bunch of searching and randomly deleting stuff in the config file it turned out that the problem was somewhere in the OpenVPN setting. I just ended up deleting that section completely. Looking on the bright side: I got to experience VI for the first time. That was… interesting. A learning experience, one might say.

    With 2.0 up and running I'm really liking it. It fixed all the performance issues I've had with 1.2.


  • Rebel Alliance Developer Netgate

    Just a guess, did you have the "OpenVPN enhancements" package installed before?

    Someone else had a similar upgrade issue with OpenVPN settings that had that package installed.



  • The first thing I do with any pf install is add nano from the cli.  The only vi command I know is how to quit :-)


  • Rebel Alliance Developer Netgate

    ee is there, no need for nano.



  • @jimp:

    Just a guess, did you have the "OpenVPN enhancements" package installed before?

    Someone else had a similar upgrade issue with OpenVPN settings that had that package installed.

    No, the only OpenVPN stuff I had installed is what came with pfSense.


  • Rebel Alliance Developer Netgate

    OK, just checking. I've had a couple other people whose configurations have failed to restore that worked when the OpenVPN section was removed, but there was no obvious incorrect entries in the config either.


Log in to reply