No number of clients connected to Captive portal reported



  • Ηello there!

    I have upgraded to 2.0. RC1 from 1.2.3. The work you have done is fantastic!
    I had some minor problems regarding the pppoe, but everything turned out ok (i had to manually remove some old remnants from config.xml)
    Also load balanced multiwan with two ADSL pppoe lines works like a charm :)

    Until 1.2.3 on the captive portal status page, i could see the number of connected clients. Now it's gone. Can i add this info somehow?
    Also , i am using a very simple html login page for the captive portal. If the client inputs the user/pass correctly (local user database), everything is OK.If the authentication fails, pfsense redirects me to it's default login page, and not the one i have created.
    Up to 1.2.3 there was not such a problem.
    I must note that i  haven't rebooted pfsense after i uploaded my custom login page.

    These are minor issues. You work is remarkable anyhow.
    My best regards.



  • Hi,

    if you click "+" on the Dashboard, you could add "Captive Portal Status Page". Perhaps this is what you are searching for? For your other questions we ne someone else to answer.



  • Thanks for your answer Nachtfalke.
    If you go to Status -> Captive portal, you get a full list of the connected clients.
    Until 1.2.3 you had the total number of connected clients appear on top.
    Something like "Connected Clients: 32"
    This report is missing on 2.0.

    Regards..

    P.S. You're the "Nachtfalke" sat guy?



  • @mrvanity:

    Thanks for your answer Nachtfalke.
    If you go to Status -> Captive portal, you get a full list of the connected clients.
    Until 1.2.3 you had the total number of connected clients appear on top.
    Something like "Connected Clients: 32"
    This report is missing on 2.0.

    Regards..

    P.S. You're the "Nachtfalke" sat guy?

    No, I don't think so ;-) It's a nickname of a pretty old roleplaygame called "Betrayal at Krondor".



  • Hi, same problem here with daily 2.0 RC firmware, the captive portal widget dashboard and the status/captive portal don't work.



  • Might be that you have this Captive Portal option enabled (ticked): "Enable Pass-through MAC automatic additions", or you have manually added the user to the mac-pass-through list.

    I recently discovered that pass-through users are not included in the status list with the 2.0 RC1.


Locked