PPPoE keep-alive value



  • Problem:

    I have a pfSense 2.0 RC1 (embedded) install with WAN configured as PPPoE client over a WiMax internet connection. Unfortunately the WiMax connection takes slightly longer than 60 secs to retrain after loosing signal (and this tends to happen quite often in bad weather!). The current default pfSense PPPoE link keep-alive 'max' value is 60, so pfSense drops and renegotiates the connection every time - causing much end-user frustration as the WAN IP change breaks a lot of session based stuff. I have manually edited interfaces.inc to bump the 'max' value to 90, which resolves the issue (PPPoE session is maintained through WiMax drops), but that has to be re-applied after firmware update or reinstall.

    Feature request:

    Would it it be possible to either bump up the default keep-alive 'max' value in interfaces.inc to something like 90, or add a configuration option for the max value in PPPoE configuration->Advanced?

    Thx,

    Jason.



  • redmine.pfsense.org
    create a feature request there.
    If you can provide a patch as well it can make faster to the repo :)


Log in to reply