Wireless for Phone as Modem (PAM) devices?



  • Is there any way to get a RNDIS driver or any sort of driver (like EasyTether) for FreeBSD which would allow me to use my phone as a temporary WAN device which I can plug in and unplug whenever I feel like it?

    The basic goal here is that I'd like to use my phone as a WAN device for my home network. Doing so wouldn't be a permanent solution and would only be used when I was around as I have my phone with me. On the other hand, if I'm sleeping or doing something like downloading large files, it might be nice to split that up among my phone and my main Internet connection. It'd also be nice to have the phone available in case the connection to the main line has issues for whatever reason.

    I'm curious what my options are here. The first one is getting pfSense to recognize RNDIS devices (universal solution) or find a way to run the Linux version of EasyTether which I also have. After that it might be difficult, but I should be able to setup pfSense to cut that line off if it's not available.

    Is this possible?


  • Rebel Alliance Developer Netgate

    Or, the much more likely to work method: Add a wifi card to pfSense and activate your phone's wifi hotspot mode, and connect that way. No need to mess with drivers or tethering, but not all phones support that.



  • That's a fantastic idea! That also means I can use my phone w/o needing a longer cable and can get faster speeds where available in the house.

    I can't get this working though. I followed http://doc.pfsense.org/index.php/Wireless_Details and get this:

    
    run0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
            ether 00:02:6f:5a:35:ed
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
            status: associated
    run0_wlan0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            ether 00:02:6f:5a:35:ed
            inet6 fe80::202:6fff:fe5a:35ed%run0_wlan0 prefixlen 64 scopeid 0x9
            nd6 options=3 <performnud,accept_rtadv>media: IEEE 802.11 Wireless Ethernet OFDM/36Mbps mode 11g
            status: associated
            ssid [HIDDEN] channel 3 (2422 MHz 11g) bssid 90:21:55:d6:2b:e4
            country US authmode WPA2/802.11i privacy ON deftxkey UNDEF
            AES-CCM 2:128-bit txpower 0 bmiss 7 scanvalid 60 protmode OFF
            roaming MANUAL</performnud,accept_rtadv></up,broadcast,running,simplex,multicast></up,broadcast,running,simplex,multicast> 
    

    Thing is, it obviously didn't connect because there's no IP and the phone has an access list. The router isn't on the access list. I have no clue what to do here.


  • Rebel Alliance Developer Netgate

    Sometimes I have seen a wireless NIC believe it is associated (but won't pass traffic) if an incorrect WPA2 key was used. Seems to only happen in certain cases though.

    If you have all the right values in the GUI (SSID, channel, etc) it should "Just Work" in most cases.



  • Hmm, I should try another Wi-Fi card then much later today.



  • Tried another adapter, I don't think anything changed. I see "OFDM/36Mbps mode 11g" but no IP still. The phone's access list isn't showing anything.

    
    ural0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
            ether 00:13:d3:76:2f:14
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
            status: associated
    ural0_wlan0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            ether 00:13:d3:76:2f:14
            inet6 fe80::213:d3ff:fe76:2f14%ural0_wlan0 prefixlen 64 scopeid 0x9
            nd6 options=3 <performnud,accept_rtadv>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
            status: no carrier
            ssid [HIDDEN] channel 3 (2422 MHz 11g)
            country US authmode WPA2/802.11i privacy ON deftxkey UNDEF txpower 0
            bmiss 7 scanvalid 450 bgscan bgscanintvl 300 bgscanidle 250
            roam:rssi 7 roam:rate 5 protmode RTSCTS roaming MANUAL</performnud,accept_rtadv></up,broadcast,running,simplex,multicast></up,broadcast,running,simplex,multicast> 
    


  • I have more info for you guys. I tried unchecking the bogon because my phone is the DHCP server here and that didn't work either. The private networks restriction was never enabled in the first place so that isn't it either.



  • Even more info, I looked at the Wireless status; it shows what I saw in command line and elsewhere. It thinks its connected, but my phone knows it's not. I wonder what's going on here that it's not working even with two adapters. I even tried changing the DHCP'd IP range.



  • I honestly can't figure out what's wrong. I even turned off the Access Control List on my phone off–which filters MAC addresses--and still can't seem to get it to connect. I connected just fine to my internal home network router even though it said the status of the connection was Offline probably because it was going through itself, but that I don't know.

    Do you want any other info on the Wireless on my phone? It should be just fine. I know the phone thinks its authenticated so that's not the problem. Seems like it's not able to receive or ask for an IP for some reason.

    Finally, I tried disabling WPA and went open. Since it's my phone, the range isn't good enough for this to be a problem. I also changed the channel from 3 to 11 to see if that would also help. I got a connection immediately. Just to see if it was the channel itself, I changed it back to WPA/2, no IP again.

    I tried a few other things. Forcing either WPA or WPA2, forcing TKIP or AES, messing around w/ Open Auth and Shared key, as well as trying an all lower-case password; none of which worked. I /could/ connect using WPA to my home router so I dunno what it is about my phone that's causing this.

    Hopefully this is enough information to go off of.



  • I kept getting the kernel to panic when I tried connecting over WPA2 using a newer version of the software or when trying Adhoc mode. I believe the phone's been in Adhoc the entire time which is why it can't connect ever unless it's got no encryption. I didn't notice because nowhere did anything tell me it was Adhoc. Even Windows showed it as Infrastructure. Even so, I can't change pfSense to Adhoc w/o a kernel panic so I won't be trying this again. Can someone verify this bug for me please?

    The newest version of the software has the ability to choose Adhoc or Infrastructure so I gave it a shot forcing Infrastructure. I think it also has a problem connecting to my phone when it's WPA/2 and Infrastructure because I had a kernel panic when it tried to authenticate; although, upon reboot, I could at least have a working system again. When I set it to Adhoc, it was consistently getting a panic as soon as it set the WWAN adapter to "up".

    I also figured out why the phone kept connecting but didn't authorize itself with the Access Control List when it was WPA :o. Any device using a Pre-Shared key wouldn't be able to connect without the encrypted key being sent back to the router (even though this is a huge security risk) yet with WPA, I'm using Open Shared Authentication so anyone can connect but cannot necessarily authorize with the access point. This is what was happening. And I think because the mode was wrong, it couldn't authenticate properly. I wonder how Windows makes it work.



  • I got it to not kernel panic while I had the device in Infrastructure mode but it still didn't work. And I'm sure if I put it back into Adhoc it'll panic again. I don't like my router going down so this isn't a thing I would like to try testing again if at all possible.


Log in to reply