Unbound and Static Entries



  • I am trying to switch to Unbound for DNS, but I am encountering a problem.

    If I turn off the DNS forwarder, I can't use all those static entries I created for local servers.  It ignores those entries completely.  Anyone know how or if this can be resolved?



  • For now, any changes made to the static entries page, requires the user to go and click 'Save' on the Unbound service page.
    If thats not the case then is your static entries resolving to private addresses at all? If so do you have 'Private Address support' enabled?

    Otherwise without other info, I can't help but assume things :)



  • All my static entries are created on the DNS Forwarding page.  (I'm assuming that's the only place they go).
    They are all resolving local/internal IPs.

    I turned support for private addresses on, yes.  Interestingly, a few of the static entries work.  No idea how or why they don't all work. It seems random.



  • Have a look at /usr/local/etc/unbound/unbound.conf, see if it has all your host entries in there? If not then let me know, pvt msg (if you don't mind) your internal host entries and unbound.conf. Want to make sure there are no funny characters that is potentially messing things up.


Locked