Static IP over pppoe and pfSense 2.0RC1



  • Hi All,

    Im having a really hard time setting up pfsense via an adsl bridge.

    Our isp provides no dhcp server, we have to specify the wan ip manually in the current router to get it connected and enable nat to get things working for the machines on the network. This however routes everything through the ip of the router, which is not the desired result as we actually have 13 ips available to us through the same connection.

    Its also worth noting its a pppoA connection with VC enabled currently

    Moving on I am setting up a pfsense firewall to operate the adsl modem as a bridge. So using pppoE? I cannot see how to setup the static IP for the adsl connection and then Im not sure how to add the extra ips we have.

    I have read on the forums that it does not support static ip for pppoe but im not sure if this relates to the older version of pfsense?

    Basically what im after is

    –<adsl bridge="" mode="">----<pfsense -="" public="" ip="" 217.155.37.20="">====== <vlan1,2>vlan 1 has a nat public ip of 217.155.37.21
    vlan2 has a nat public ip of 217.155.37.22
    x machine on vlan2 has a public ip of 217.155.37.23 (a server)

    and so on.

    Any help with this would be appreciated.

    If it cannot support this kind of setup how can i configure the network so i can allow pfsense to manually assign each vlan its own public ip etc, maybe put the adsl modem back into bridge mode?

    Thanks
    Ryan

    Hardware
    PFSense Router with 2 nics
    and use of either

    DGN2200 Wifi router
    Zoom X6 Wifi router
    Zyxel (although this seems to have died after repeated config changes!!)

    TPLINK 8616 modem</vlan1,2></pfsense></adsl>



  • Hi all, if it helps this is the kind of connection I am trying to mimic in the pfsense with the TP-8616

    This screendump is taken from the netgear router.



  • Hey. Have you tried to setup a PPPoE connection without the static IP? I had the same problem, missing the static IP option. Then I just typed in the date from my ISP and connected without the static IP option. I received the correct IP from my ISP.

    Cheers



  • Yep, thats how i got it working in the end. Was a misunderstanding on my part on the connection information from the ISP. Didnt help that it was taking 20mins to connect 1st time so i just assumed it didn't work!



  • Have you checked your Subnet mask? I'm receiving an 255.255.255.255 Subnet mask. Guess that's not the it should be in the end :/.

    Cheers



  • For many ISPs that is the right netmask.



  • Your modem page shows natting turned on…  If this is supposed to be bridge mode wouldn't that be off?


  • Netgate Administrator

    Those are setting's he is (now successfully) mimicking on pfSense.

    Steve


Log in to reply