Problems mounting PfSense 2.0 RC1 onto a Netgate Hamakau Firewall



  • Hello,

    I am new at this, but currently trying to install the PfSense 2.0 RC 1 (2GB) from this site PFSense 2.0 onto a 4GB Scan Disk Card. I've tried mounting the 2GB image to a 2GB card, and an error is created when mounting. I read on this board in the "Slightly undersized CF cards with nanobsd images?" topic that it is ok to mount a smaller image on a larger card. I successfully completed a checksum on the  2GB image before I mounted it on the 4GB card. I used the RoadKil program to mount the image as recommeded in this thread. After using the roadkill program it said the image has been successfully created.

    With the image successfully mounted I put the card into a Hamaku Firewall and go through the startup procedures for the Netgate Hamakua 1U Rack Mount Network Appliance. At this time I should be able to see the device startup using Putty or Hyper Terminal, however I don't see anything. When I put the original SD card that came with the device in the Hamakua and follow the same startup procedures to connect serially, I see the device startup and send information over Putty. I have also tried using the stable version of PfSense pfSense-1.2.3-RELEASE-2g-nanobsd.img.gz, and I have the same issue where I am unable to see anything on Putty or Hyper Terminal. Therefore, I believe I am have a problem with mounting the image.

    My question is how do I know my PfSense image is being mounted properly, and are there any steps I am missing in this process?

    Thank you!



  • To make my question more clear, when I boot up I don't see a screen  like this


  • Rebel Alliance Developer Netgate

    IIRC the Hamakua boxes ship with a slightly altered firmware. Have you tried using the image from Netgate?

    http://doc.pfsense.org/index.php/Embedded_install_on_Netgate_Hamakua



  • Is there an up-to-date howto, wiki, or guide on getting pfSense 2.0(rc) onto a Hamakua without the VGA cable?  I saw the guide on using VMware, which is fine but I haven't tried it and it seems  a bit outdated.  Wanted to know before I plunk down $1200 for 2 more units if it's possible to get 2.0 on them without too much headache.


  • Rebel Alliance Developer Netgate

    You're wanting a full install or NanoBSD?

    Netgate may have a doc they can send you, but the VMware method was right last time I heard for a full install. Same general procedure should work for both 1.2.3 and 2.0 I thought.



  • I was wanting to do nanobsd-  I don't want to install hard drives or SSDs in them (not using squid).  Is it possible to do without the serial cable?


  • Rebel Alliance Developer Netgate

    Sure, with embedded it's easy. Just use dd/physdiskwrite/something else to write the embedded image to the CF. I thought Netgate even had 2.0 images for the Hamakua with the right bits set on them to boot correctly. Check their website or e-mail their support, they're a good bunch of guys they can point you in the right direction. (Especially if you let them know you're looking to order more. :-)


Locked