Problem w/ GT701 DSL and PFsense



  • I've tried for sometime to track down this problem, and I'm hoping another one of you gurus out there could help me out.  We switched from a cable provider to DSL, that has 7 megs down and 1 up, (2 megs faster than the the original cable connection).  The ADSL connection uses PPOA authentication that occurs on the actiontec GT701 gateway itself. 
    So its goes
    Internet 71.91.xxx.xxx
    |
    Actiontec 10.10.10.1/24
    |
    Pfsense WAN 10.10.10.10/24
    |
    Pfsense LAN 192.168.104.0/22

    I had traffic shaping installed and turned it off, and I also use to run squid but it has been removed.  The bare bones system has the following problems:

    Some pages resolve very quickly and others slowly, pages that are particularly slow are pages involving authentication
    Some pages say they are done but on many of the client machines they just have a white screen
    Some pages load partially and then just got lost until it times and switches to this page cannot be displayed
    When downloading, sometimes the download will get 1/2 to 3/4 of the way done and then just stop downloading

    What I've tried:

    Changing the MTU size, when doing a ping -f -l to the gateway though, I can send 1472, add 28 and that = 1500 so it should be fine if I understood hoba's post on this.

    Assigning the ISP DNS server directly via dhcp to client machines

    Changing the modem and pf to a 208.132.12.0/24 segement for their connection

    Several different DNS servers assigned to Pfsense including those from the ISP and those that are not from the ISP, note that I did uncheck the box allowing the DSL modem to override these servers.
    *Note also that pings go through fine, and everything seems to resolve alright

    Tried several different modems, which were all the same model actiontec, 2wire is on order to try out.

    Unchecked block private/bogon

    In system > advanced > I tried to say clear DF instead of dropping segmented packets

    I'm really not sure what to think at this point, I haven't had problems with PFsense on DSL connections in the past, I'm hoping that I just missed something simple that someone could chime in for me.  Any suggestions would be appreciated.



  • If anyone stumbles onto this post, just know that the problem can resolved as mentioned in other posts by using PPPoE on your pfsense box and switching your modem to transparent bridge mode, my isp said that PPPoE isn't supported, but it still works, and works much better.



  • I think I'm getting this too. I get HUGE packet loss on the line behind their modem. Currently its setup so that pfSense is the DMZ system, so it NAT's all packets to the pfSense system. The performance is horrible.

    It seems to run fine for awhile then eventually (6 hours) will start to drop packets. Also the states are very high so it must not be expiring connections ??

    I'll try going into PPPoE mode.. if I can find it on that stupid Verizon Modem..


Log in to reply