Update from 1.2.3 to 2.0-RC1 - OpenVPN adding Rules failed



  • Hi Folks!

    so long…i have fresh updated my pfSense box from 1.2.3 to 2.0-RC1. The migration worked nearly flawlessly. I only had problems with some NAT rules wich i just had to re-create and than it did work. Also i had the typical interface missmatch, but that was no problem to solve. Then i have had to set up the entire openvpn settings from scratch, because they have not been migrated. so i created a server certificate + ca and an OpenVPN profile at the "openvpn" page.

    but the problem i still cannot solve is, that i cannot add any openvpn rules. clients are able to connect and they get an ip address assinged, but they cannot connect anything inside my network. it's logical, when there are no openvpn rules existing.

    the i tried to add a passing rule for my openvpn-clients on the openvpn intrerface which appeard then at the "rules" page. but i get the following errors at the filter reload:

    php: : There were error(s) loading the rules: /tmp/rules.debug:241: syntax error /tmp/rules.debug:252: syntax error pfctl: Syntax error in config file: pf rules not loaded - The line in question reads [241]: pass in log quick on $OpenVPN from 10.10.10.0/24 to 172.16.172.0/24 keep state label "USER_RULE: OpenVPN"
    
    

    everything is working, except the openvpn rules. i cannot add any rule on the openvpn interface…

    hope someopne can help me!

    regards
    Fabian


  • Rebel Alliance Developer Netgate

    It sounds like your config was not properly imported, and may have caused other issues. The things you mentioned should have been carried over without issue.


Locked