Openosfp working in 2.0 RC-1, but previous version



  • Hi all:

    I have installed openospf by the package manager. The manager install version openospfd-4.6.tbz (I don't know why in package manager say version 0.5.1). If you configure redistribute default route don't work. Pfsense lose the default route.

    But if you install previous version openospfd-4.3_1.tbz from the repository:

    http://files.pfsense.org/packages/8/All/

    this version works right. You must to install it from the ssh in the comand line.

    Will be posible to disable 4.6 to install 4.3 from the package manager?

    Best regards



  • Can you be more specific on what you claim?
    Provide any logs! What does not work?! etc…

    Lots of people use 4.6 of OpenOSPFd and do not have issues with ti.



  • I have a network based in mikrotik:

    http://www.guifi.net

    Pfsense is the firewall who permit internet access so is the default gateway for all the nodes. It neigbord is the mikrotik and pfsense learn the routes from the mikrotik and mikrotik learn the routes from pfsense. Only pfsense is distributing the default gateway. No more devices distributing the default network. To here, all right.

    The only problem is that pfsense lose the default gateway (itself) and don't distribute it to the other nodes. If I unistall the package and install manually the old version, the configuration of previous installation still in the system and the new installation take it. Not needed to configure the new installation because the config files are the same that previous version (not deleted from the unistall action). The new installation take the previous installation and all is working. With the same configuration, the newest version don't work, and the old one work perfectly.

    Best regards.



  • Can you provide any logs on this and your ospf config?



  • Here the generated ospfd.conf file by the gui:

    router-id 172.18.0.1
    redistribute default
    area 0.0.0.0 {
            interface sk1_vlan200
            interface sk2_vlan201
    }

    Is a simple configuration :-). When I will install the next one I will do it with the last version. Then I will paste the logs.

    Best regards.


Locked