DHCP client on WAN interface broken in 2.0-RC1 ?



  • I'm using pfSense on a leased root server from Strato.
    They have a somewhat special network config.
    The server has a /32 netmask and needs an additional
    interface route to the default gateway.

    With 1.2.3 DHCP on the WAN interface works out of the box .
    With 2.0-RC1 the default route is missing.

    On the shell I can add the routes by hand:
    route add -host 85.214.128.1 -link em0: -interface
    route add default 85.214.128.1

    Where should I add the routes?
    In the GUI? In some files?

    Any comments are welcome!



  • @quisam2342:

    With 1.2.3 DHCP on the WAN interface works out of the box .
    With 2.0-RC1 the default route is missing.

    Which build of RC1? RC! install or upgrade from 1.2.3?

    @quisam2342:

    On the shell I can add the routes by hand:
    route add -host 85.214.128.1 -link em0: -interface
    route add default 85.214.128.1

    Where should I add the routes?
    In the GUI? In some files?

    You could start in System -> Routing, click on the Gateways tab and the clik on "+" to add a gateway.

    Since 1.2.3 worked without special tweaks for the default route I'd guess 2.0 should also. Depending on what build of 2.0 RC1 you used you may get better results with a recent snapshot build of 2.0 RC1.



  • @wallabybob:

    Which build of RC1? RC! install or upgrade from 1.2.3?

    I have done a fresh install of pfSense-2.0-RC1-amd64-20110226-1807.iso

    Now I made an upgrade to the Latest Version: Sat Mar 26 00:18:39 EDT 2011. The problem still exists.



  • Content of /var/db/dhclient.leases.em0:

    lease {
      interface "em0";
      fixed-address 81.xxx.xxx.210;
      filename "pxelinux.0";
      option subnet-mask 255.255.255.255;
      option routers 81.xxx.xxx.1;
      option domain-name-servers 81.169.163.106,85.214.7.22,81.169.148.34;
      option host-name "hxxxxxxx";
      option domain-name "stratoserver.net";
      option dhcp-lease-time 86400;
      option dhcp-message-type 5;
      option dhcp-server-identifier 85.214.7.21;
      renew 3 2011/3/30 02:06:58;
      rebind 3 2011/3/30 11:06:58;
      expire 3 2011/3/30 14:06:58;
    }



  • With this little hack it works for me:

    /etc/dhclient-exit-hooks:
    #!/bin/bash
    if netstat -nr | grep -q '^default'; then
     # default route exists
    else
     route add -host $new_routers -link em0: -interface      
     route add default $new_routers      
    fi


Locked