• System: Pfsense 2.0-RC1 amd64

    I tried to install nrpe with pkg_add -r nrpe2 and configured this service.
    Then i tried to check some things from my nagios server. I get always Socket timeout after 10 seconds.
    After some testing i found out that the nrpe package in bsd is compiled without ssl.
    I work 99% with Debian Linux and the pfsense is my only bsd System.
    How can i create a package with ssl?

  • ok i solved this problem.

    If somebody is interested:

    First setup a virtual maschine of freebsd
    In the NRPE ports dir edit the Make File and enable SSL
    make config recursive
    make package recursive

    put the nrpe package on the pfsense host

    install the depend packages
    and install nrpe
    pkg_add PATH TO PACKAGE
    edit nagios config file and enable nrpe in the startup script

    now nrpe should work with ssl

Log in to reply